[Solution] Kasa devices reboot randomly

[Solution] Kasa devices reboot randomly
[Solution] Kasa devices reboot randomly
2021-04-25 09:26:49 - last edited 2021-09-24 08:07:44
Model: HS103
Hardware Version: V3
Firmware Version:

This Article Applies to: 
HS103, HS210, HS220, HS200, KP303, KP400,KP105,KL110,KL130

 

Some customers may find that some of their Kasa devices would randomly auto-reboot (randomly goes off and quickly back on in a sec). This article aims to guide you to get this resolved.

 

Issue Description/Phenomenon

 

How to determine whether a Kasa device is encountering an auto-reboot, check the below phenomenon:

1) Kasa Device’s LED lights status. When a Kasa plug auto-reboot, the LED light will turn off and then turn on quickly. For a Kasa switch, the Wi-Fi indicator will light up quickly, change to be flashing green, then solid green, then turn off finally. For a Kasa bulb, it will flicker quickly.
 

2) Electrical appliances connected to Kasa devices. For example, when a Kasa plug auto reboots, the equipment connected to the plug will suddenly lose power and resume immediately. When a Kasa switch auto reboots, the bulb/lamp connected to the switch will suddenly dim or flicker.

 

Available Solutions----Updated on Apr 30, 2021  Added KP105 (UK) V1 Beta

The developer has provided some beta firmware for certain Kasa models to resolve the auto-reboot, upgrade the firmware of the problematic Kasa devices to this version, monitor a few more days, and check if the auto-reboot is gone

 

KP105(UK)_1.0 : https://static.tp-link.com/beta/2021/202104/20210430/Upgrade_Instruction_KP105_UK_V1_fix_auto_reboot_issue_04_30.zip

KL110/KL130_V2 :  Fixed on firmware 1.0.11 and later firmware.

HS103(US)_V2: https://static.tp-link.com/beta/2021/202103/20210324/Upgrade_Instruction_HS103_V2_fix_auto_reboot_issue 03 24.zip

HS103(US)_V3: https://static.tp-link.com/beta/2021/202103/20210325/Upgrade_Instruction_HS103_V3_fix_auto_reboot_issue 03 25.zip

HS210(US)_V2: https://static.tp-link.com/beta/2021/202104/20210402/Upgrade_Instruction_HS210_V2_fix_auto_reboot_issue04_02.zip

HS220(US)_V2: https://static.tp-link.com/beta/2021/202104/20210407/Upgrade_Instruction_HS220_V2_fix_auto_reboot_issue 0407.zip

( If factory reset did not succeed on HS220, try turned off the WiFi that the switch was connected to.  Shared in post HS220 Rebooting solved  by @dhigby  )

HS200(US)_V4: https://static.tp-link.com/beta/2021/202104/20210407/Upgrade_Instruction_HS200_V4_fix_auto_reboot_issue0323.zip

KP303(US)_V1/KP303(UK)_V1/KP303(AU)_V1: https://static.tp-link.com/beta/2021/202104/20210413/Upgrade_Instruction_KP303_V1_fix_auto_reboot_issue 04_13.zip

KP400(US)_V2: https://static.tp-link.com/beta/2021/202104/20210416/Upgrade_Instruction_KP400_V2_fix_auto_reboot_issue 04_16.zip

Note:

1) There is a word document in the folder providing detailed instructions to upgrade the Kasa firmware.      

2) Please save the downloaded file to the desktop, unzip and open it on the desktop.

3) Please use a Windows computer whenever possible.  

 

Troubleshooting Tips

 

For the following suggestions, perform one at a time:

Step 1

Check and ensure both the Kasa device's firmware and the Kasa app version are up-to-date. If not, update first.

Step 2

Factory reset the Kasa device by pressing the Reset button for 10 secs, keep it in the factory default state and observe whether it will reboot or not. 

Step 3

Create a new isolated network on your home network and only let Kasa devices connect to this network.

 * About isolated network:

1. If your router supports "Guest Network", please turn on "Guest Network" and you can take it as an isolated network. 

2. If your network devices support setting “multi SSID” or “VLAN”, please create a new multi SSID/VLAN, and only let the Kasa devices connect to it. It will isolate Kasa devices too. 

3. If you have an old router, please connect the old router behind the main router. Assign the new router a different set of IP addresses (like 10.0.10.1) and then assign some smart plugs and switches to the new router. 

Note: Do not connect your phone or other Wi-Fi devices to that Guest Wi-Fi/ isolated network that the Kasa devices are connected to, check first if the auto-reboot problem stops or not. As certain device may cause the Kasa device to reboot.

If the issue is gone after you created an isolated network, you could then connect mobile phone and other Wi-Fi devices gradually to see if any device will trigger this reboot issue. 

Step 4

If you’re using a Mesh network, try to disable the "fast roaming" and "beam forming" on the mesh devices. 

Step 5

If your host router is Arris TG1682G, please try connecting the Kasa device to a different model of router or Wi-Fi extender.

 

If the troubleshooting tips and the beta firmware still don’t resolve the auto-reboot issue, report back by submitting a diagnostic via email with the Subject ‘TP-Link Community- [Forum ID 262328] Kasa devices reboot randomly, or leave a reply on this thread. In either case, be sure to provide the following information:

- Troubleshooting steps you have taken:

- The detailed network topology/layout (like modem-router-AP. More detailed network topology helps more, like the model of network devices and the network segment, like 192.168.1.0):  

- The brand and specific model of the host router:

- The frequency of the auto-reboot:

- Are there other Kasa devices that can work properly without an auto-reboot? 

0
0
#1
Options
5 Reply
Re:[Solution] Kasa devices reboot randomly
2021-08-13 16:46:07
Hopefully this helps someone if your wifi supports it, I found an easy workaround which was to enable L2 Isolation mode on my existing Unifi SSID (Ubiquiti). Then the HS220 v2 devices did not reboot and I could upgrade like normal (I saw version 1.0.8) with the Kasa mobile app. I could not get the devices to consistently reset during the constant 30 sec boot cycle no matter how I timed hitting the reset button. This is basically doing the same thing as the guest network setting to isolate the network but without having to make a lot of changes to your network. cheers!
2
2
#2
Options
Re:[Solution] Kasa devices reboot randomly
2021-09-08 04:37:39 - last edited 2021-09-08 04:48:11

@Solla-topee 

 

Will the beta / release update disable local control (Home Assistant) for North American / US devices?

 

This has been happening to my devices too recently, latest firmware.

It's only happening on my HS103 devices HW v2.1, FW 1.1.4.

Older HW devices seem to be immune.

 

I have about 24 TP-Link devices (HS100, HS103, KP400, HS200, HS220).

 

I use 3x Omada EAP 245 V3 APs on latest firmware and controller version.

I have "AI Roaming" turned on, 2.4 GHz channel utilization isn't too bad.

All my IoT devices are on a dedicated VLAN + SSID.

 

When they're in the "frozen state" they become unavailable in Home Assistant and the Kasa app until they complete their reboot.

 

 

2
2
#3
Options
Re:[Solution] Kasa devices reboot randomly
2021-09-08 08:08:52 - last edited 2021-09-08 08:17:58

@WirelessForEver  Hello,  

HS103 V3 1.1.4 is newer than the beta firmware, and should have fixed this issue. Can you help describe how does HS103 reboot ?

The beta or the latest firmware does not  disable the local control, so it should not affect the Home Assistant. You could create a separate SSID on EAP and set is as a Guest network/ Isolated network, only let HS103 connect to it, do not connect your phone or computer to that Wi-Fi and see if the issue is gone.  

At the same time, we would like to have a specialist look into this further via email. Please check your mailbox later, and let us know if the issue is resolved. Thank you!

 

0
0
#4
Options
Re:[Solution] Kasa devices reboot randomly
2021-09-08 08:27:05

 

Solla-topee wrote

@WirelessForEver  Hello, 

Can you help describe how does HS103 reboot ? How many HS103s  do you have, did they reboot together ? 

HS103 V3 1.1.4 is newer than the beta firmware, and should have fixed this issue. 

The beta or the latest firmware does not  disable the local control, so it should not affect the Home Assistant

You could create a separate SSID on EAP and set is as a Guest network/ Isolated network, only let HS103 connect to it, do not connect your phone or computer to that Wi-Fi and see if the issue is gone. 

 

 

 

 

Thanks for the reply!

 

The odd part is the HS103 V2.1 devices never used to reboot before 1.1.4.

They were on the previous firmware version (I forget the version) with no problems.

There have not been any network changes or changes to the RF environment.

One of the APs is one room over and the problematic HS103s are about -40 dBm in the Kasa app and about the same in the Omada controller.I don't have any problems from Microwaves, etc.

There are no regularly scheduled port or vulnerability scanners on this subnet/SSID.

They do not reboot together.

 

My other Kasa devices are all fine as described above and on the same subnet/SSID.

I have a HS220, older HW HS103 and HS100 in the same room and they do not do reboot/go unavailable.

 

They do an orange blue, pause, blue blue blue blue blue when the reboot.

They come back up in Kasa and Home Assistant very fast after this.  From my Home Assistant logs, they go unavailable for on average about 30 sec (it takes a little longer for them to come back up in the Kasa app).

To confirm, this blink code means that they are rebooting and not roaming to a different AP?

 

I'll setup a new SSID and also ensure the problematic HS103s have affinity to a single AP and do not roam.

 

Thanks for the help!

 

2
2
#5
Options
Re:[Solution] Kasa devices reboot randomly
2021-09-08 09:04:44 - last edited 2021-09-08 09:07:38

@WirelessForEver  Hello, 

If the WiFi LED become orange, the plug lost Wi-Fi temporarily. Plug Wi-Fi connection was interrupted it could be roaming or reconnect to WiFi at that time. 

The auto- reboot phenomenon is different, the plug just randomly turn on and immediately turn off in 1- 2 secs, Wi-Fi Led is Solid Green at that time. 

Forcing HS103 to stick on a single AP, not roam between AP sounds like a good idea, feel free to let us know result whenever you get the chance, thank you.

 

0
0
#6
Options