Connect to 2.4 GHz radio

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Connect to 2.4 GHz radio
Connect to 2.4 GHz radio
2017-12-03 04:20:59
Model :

Hardware Version :

Firmware Version :

ISP :

I've got some etekcity "smart" plugs that can be set up only from a 2.4 GHz network. How can I specify which network to connect to on the Deco?

Apologies if this has been answered; I couldn't find it in my searches.

Thanks
0
0
#1
Options
9 Reply
Re:Connect to 2.4 GHz radio
2017-12-04 17:06:17
There is alway two WiFi networks from the Deco, but with the same name.
So dont worry about it, you smart plug will be able to see the Deco WiFi signal, no issue at all.
0
0
#2
Options
Re:Connect to 2.4 GHz radio
2017-12-04 21:25:06
Hi Matt,

It's not about the plugs being connected, it's about the setup. The silly app won't run on 5GHz networks, so I need to force my phone to connect to a 2.4 radio.
1
1
#3
Options
Re:Connect to 2.4 GHz radio
2017-12-05 14:07:22
Hi SirSpidey, sorry, but I still don't see what the problem is?
As the Deco always broadcasts 2.4G WiFi signal, so both the plug and the phone should be able to connect to the Deco network.
0
0
#4
Options
Re:Connect to 2.4 GHz radio
2017-12-05 19:18:55
Here's a screenshot that might explain the situation. "Should be able to connect" wouldn't be an issue if the app developers didn't care which radio it connected to.

So the question is how to force a connection to a 2.4GHz radio.



0
0
#5
Options
Re:Connect to 2.4 GHz radio
2017-12-06 19:40:01
I see, how weird this is though, here's my suggestion:
Bring your mobile phone a bit further from any of the Deco units, it would automatically switch to 2.4 GHz WiFi.
If you have an Android mobile phone, you can tell by the link speed, if the link speed drops to 150Mbps or 72Mbps, you would know for sure the mobile now is connected on 2.4GHz.
0
0
#6
Options
Re:Connect to 2.4 GHz radio
2019-07-06 18:22:48

The thread is rather old, but it is still relevant, so I'll add an answer: Take a look at : My device is only compatible with 2.4Ghz networks.

In summary (for Android users):

 

Android users can force the mobile to connect on 2.4Ghz and once connected on 2.4Ghz, you setup the device. Some examples of devices that this method works for are: Etekcity Smart WiFi Plug, TP-Link Smart Wi-Fi Plug Slim, Eques Elf, WyzeCam. There are two ways to force your Android to connect on 2.4GHz, which depends on the version of Android OS you are using. 

  • Method 1 (Android 6.0.1 and earlier)
    1. Open your Android device’s settings menu.
    2. Tap Wi-Fi then the three dots in the upper-right corner.
    3. Tap Advanced > Wi-Fi frequency band.
    4. Select the desired radio band.
    5. Once connected on 2.4Ghz, use the App to setup you smart device.
    6. Switch your Android back 5GHz  
  • Method 2 (Android 7 or higher)
    1. Download and install Wifi Analyzer by Farproc and the Wifi Connector Library (both free) on your Android device
    2. Forget your Plume network on you Android device
    3. Open Wifi Analyzer and swipe right until you get to the AP List page.
    4. You will see several pods broadcasting on different bands
    5. Long-press on the strongest one broadcasting on a 2.4GHz channel (1,6,11) and choose Connect.
    6. Enter the Wi-Fi password and your phone will now be connected on 2.4GHz
    7. Use the smart device App to setup your smart device.
    8. Once the device is connected, forget the network on your Android device and set it up again using the normal method.

 

Method 2 worked for me...

0
0
#7
Options
Re:Re:Connect to 2.4 GHz radio
2019-07-07 18:48:32 - last edited 2019-07-07 18:53:29

Latest Deco firmware allows disabling either 2.4 or 5 gig radio.  Just turn off the one you do NOT want, connect to the one you DO want, then turn the other back on.  That is how I was able to connect to my weather station which would not connect with both turned on.  Once connected I turned the other on.  This seems to be a DEVICE issue not DECO since devices should be smart enough to connect to the freq they need.

 

I have at least five  2.4gig only devices and only the weather station is a problem (which the manu is aware of but won't fix it).

 

Edit:  Geez!  This thread is over 2 years old.  I would think this is a non-issue by now plus the OP wasn't inquirng about Android devices but etekcity "smart" plugs.

0
0
#8
Options
Re:Re:Re:Connect to 2.4 GHz radio
2019-07-23 02:25:29

The issue isn't that the device can't connect to the 2.4Ghz network - it can.  The problem is that your phone will always connect to the "best" network it can, which will be the 5Ghz network if you are anywhere in your house, so your phone and your device will NOT be on the same network.  It totally makes sense that devices ship with only 2.4Ghz radios - it has better transmission range and penetration, and for low-bandwidth devices like weather stations and Hue lights, it makes no sense to spend extra money adding a 5Ghz radio to them.  What *doesn't* make sense is shipping the M4 & associated application with no way to turn off the 5Ghz radio in the deco temporarily so someone can hook up their 2.4Ghz devices - huge oversight and usability issue.  I suspected I was going to have to move far away from my network to force my iPhone to connect to 2.4Ghz, but that's kind of a ridiculously hack workaround for a usability issue with the Deco app...

0
0
#9
Options
Re:Re:Re:Re:Connect to 2.4 GHz radio
2019-07-25 21:59:10

@Bob_in_NH 

 

All Decos use ART (adaptive routing technology).  You setup one network name and password the the router will intelligently choose the band a device will connect to based on device capablities, distance from the AP and the traffic bandwidth needs.  This is why sometimes a device capable of 5GHz is connected to only 2.4GHz.  based on the needs and traffic requirements 2.4GHz was sufficent.  This also frees up band constriction and congestion for the devices that actually need it. Having 5GHz active should have no affect on devices that cannot connect to it.

0
0
#10
Options