I was sent a replacement router that cannot utilize 5GHz - Unbelievable

I was sent a replacement router that cannot utilize 5GHz - Unbelievable
I was sent a replacement router that cannot utilize 5GHz - Unbelievable
2018-11-25 02:23:30

I cannot even begin to express my frustrations right now. 


This is the old thread I started, with explanation of what was going on with my C5400. Basically; the 2.4GHz network is dying after only 1 year of owning the router. 


I requested an RMA after sticking it out with tech-support and going through multiple redundant tests, which produced no results. Finally my RMA was approved, and my new unit was sent to me. I unboxed and plugged in my replacement unit today to be greeted with the message "The 5GHz network cannot be used due to restraictions in your region/country."


I live in the US and am on FiOS, 5GHz wifi is not restricted. I must have been sent a defective router, or one manufactured for a different region of the world. I don't even understand how this could happen. I'd very much like to actually get a fully-functional replacement for my replacement (ha) that hopefully works for more than 1 year. On top of all that, the C5400 is NOT a cheap router...I cannot believe I paid that much money for such a product, and service like this. 

2 Replies
Re:I was sent a replacement router that cannot utilize 5GHz - Unbelievable
2018-11-29 17:47:17




I can deffiantly understand your frustration on this and defiantly do not want this to be the kind of experiance you recieve from our products and support.  This error has happened on a very small amount of the C5400 routers and is typically fixed with a firmware upgrade.  I would first recommend that you upgrade the firmware, power cycle the router and then test the connection.  If it still fails then a 2nd replacement would be needed.  If you have already upgraded the firmware or it fails please respond to this post and we will reach out to you with steps for the replacement.  



Best Regards


Carl | TP-Link Support 

Re:I was sent a replacement router that cannot utilize 5GHz - Unbelievable
2019-09-09 15:26:13

I took a look at the source code and found a work around for this. I tried it las night. works like a charm

The rule that applies protection against using 5G in restricted countries happens in a part of the code where NO RULES LIKE THIS SHOULD EXIST! These are SIMPLE SOFTWARE DESIGN PARADIGMS.

The error happens when the wireless transmitter SWITCHES CHANNELS, but a specific scenario pushses your router into "Malaysia Mode" (what kind of crap country isn't allowed to have 5G)


0.5) if you havent already MANUALLY flash your firmware to latest through here https://www.tp-link.com/us/support/download/archer-c5400/v2/#Firmware

  1. Flash/Factory reset your router with the reset pinhole button back to factory 
  2. Plug in ethernet cable directly to the router and the device you will manage it from (very important, we are going to disable wireless from the get-go to get the router in the correct state)
  3. After your router boots up after factory reset, go to tplinkwifi.net to follow the setup wizard
  4. Go through this like normal, EXCEPT
    1. SET YOUR TIME ZONE TO CENTRAL (we'll correct this later if it's not your timezone) 
    2. When you get to the part where you specify your internet connection, there's an "advanced" section button. In that section there is a drop down to specify a country mode. 
      1. SELECT MALAYSIA FIRST, THEN SELECT NONE. this is just to ensure that this drop down wasn't accidently triggered
    3. When You get to the screen to name your Access points and give them passwords. !!!DISABLE ALL OF THE ACCESS POINTS. WE DO NOT WANT WIRELESS ACCESS POINTS ON UNTIL THE VERY LAST PART !!!
  5. The setup wizard should be complete at this point and you should have no wifi
  6. Go to Advanced > System Tools > Time 
    1. Set/replace The NTP Servers to the following below:
      1. 0.north-america.pool.ntp.org
      2. 1.north-america.pool.ntp.org
    2. Select your CORRECT TIME ZONE
    3. Click "Obtain" and let your router (assuming it has access to the internet) obtain the correct time from those new NTP servers 
    4. As soon as it resolves the correct time, click SAVE
  8. Log back in after reboot, go back to time and confirm the CORRECT TIME IS NOW SET EVEN AFTER THE REBOOT
    1. If correct time is not set, redo everything until it can hold the time after a reboot
  9. Go to Advanced > Wireless and let's setup the wifi access points
    1. The main goal of this part is to eliminate any thing that says "AUTO", we want to manually select every option, if we let the router auto select, it will just go back into country restricted mode
    2. On Each access point (2G, 5G1, 5G2), select the LARGEST WIDTH (i think it's 40Mhz for 2G and 80Mhz for 5G... whatever the largest number is)
    3. On Each access point (2G, 5G1, 5G2) select the LAST CHANNEL NUMBER AVAIABLE (I think 2G is 11, 5G1 is 80, 5G2 is 160... whatever the highest number is in those drop downs, use those)
    4. On Each access point (2G, 5G1, 5G2) select AES encryption (probably doesnt matter, but we DO NOT WANT THIS ROUTER TO EVER AUTO SELECT ANYTHING)
    5. On Each access point (2G, 5G1, 5G2) Select an authentication method that suits your password needs (WPA2 non-enterprise is usually the standard)
  10. Save, Save, Save
  12. Log back in, go to advanced, go to "internet" (i forgot the name of the drop down, writing all of this from memory at work) nd make sure you unselect the checkbox that says "igmp proxying"... we want to disable that
  13. SAVE. 
  14. Make any other changes youd like... (i disable the firewall and anti virus nonsense because its a piece of crap and uses too much of the available memory and CPU)
  15. Save... reboot... enjoy


Working without issues last 6 hours. 
If anyone can post screen shots while they do this to help make it easier for more novice users, that would be a..


Let me know if it works out for you guys as it did for me.