"Invalid RSA public key"

"Invalid RSA public key"
"Invalid RSA public key"
2020-03-26 13:54:04
Hardware Version: V1
Firmware Version: v 1.200121

For the last 5 days I get this error message when I try to log in to the router page. It only happens on my desktop. I've tried clearing the cache, but no luck.

0
0
#1
Options
8 Reply
Re:"Invalid RSA public key"
2020-03-26 16:17:28
see https://www.tp-link.com/us/support/faq/2657/
0
0
#2
Options
Re:"Invalid RSA public key"
2020-03-26 16:31:27

@ArcherC8 

I did that. No luck.

1
1
#3
Options
Re:"Invalid RSA public key"
2020-03-26 18:26:30

@mbcdaltx 

 

Have you tried running Chrome in incognito mode or used FireFox or IE?

0
0
#4
Options
Re:"Invalid RSA public key"
2020-03-26 18:37:56

@Tony 

 

Yes and I've tried 3 different browsers. It's only happening on my desktop no otther devices.

0
0
#5
Options
Re:"Invalid RSA public key"
2020-03-27 10:57:55
Sounds like you may have some host file issues on that PC. Getting a bit beyond my knowledge. There are many web pages where it shows how to clear/remove the hosts but not sure what the impact is if you do. If it is a MAC, I would use Time Machine and go back to a previous date before the issue started. If Windows, do the same if you have the backup. I am not much of a Windows 10 person, but I would think you could reinstall Wimdows 10 preserving user data might work.
0
0
#6
Options
Re:"Invalid RSA public key"
2020-03-27 13:29:36

@mbcdaltx 

 

Within the URL are you typing https? If so just put: http

 

The error is usually found when trying to use SSL.

0
0
#7
Options
Re:"Invalid RSA public key"
2021-01-04 21:04:48

@ArcherC8 

Reinstalling Windows because you cannot sign into a TPLink router would be a terrible recommendation.

 

 

 

 

0
0
#8
Options
Re:"Invalid RSA public key"
2021-10-08 00:14:25

@mbcdaltx 

I have this issue too. It only happens on one computer and it doesn't matter what browser I use. If I cold boot the router (C7) then I can login as normal just using my existing password. After sometime (I haven't determined how long) it reverts to the prompt that I have to create an administrator password and even if I try any word I get the invalid RSA public key error. If I try from another computer at anytime I can log in without issue. I can also login using the Tether app at anytime also. So, it seems to be PC (or probably MAC address) related. It would be good if there was response from TPLink support about how to resolve this issue.

0
0
#9
Options