Deco x20 connection speed drops

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco x20 connection speed drops

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco x20 connection speed drops
Deco x20 connection speed drops
2020-08-29 09:10:39
Model: Deco X20  
Hardware Version:
Firmware Version:

When I connect to the router I'm able to get 50-60mb/s. Which is around 900mbps.

But my deco x20 somehow always drops it to 10mb/s. The weird thing is that it's not a limited speed. I can reboot the mesh unit and it will go up to 50mb/s when freshly rebooted. But after a few hours, if I come back, it'd drop back to 10mb/s again. 

I tried setting everything to default (not setting any QOOS, or priority device.) I tried deleting the network and setting up a new network. 

Meanwhile my ISP router is clocking consistently 50mb/s. And the main deco unit is connected to the router via LAN cable.

 

The problem still persists. I'm starting to think that I made the wrong choice of purchasing the set. Is there anything that I can do to resolve my issue? 

  2      
  2      
#1
Options
6 Reply
Re:Deco x20 connection speed drops
2021-09-02 08:14:40

@weechuen I am having the exact same issue.

Did you manage to figure out the cause or solution?

  0  
  0  
#2
Options
Re:Deco x20 connection speed drops
2021-09-03 05:38:42

@Fr0stY 

Hi, could you please provide more details about your current issue like the opener, like how much of your internet bandwidth?

Did the speed recover after restart?

It would be highly appreciated that you could provide as much information as possible.

 

 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#3
Options
Re:Deco x20 connection speed drops
2021-09-03 06:48:12

@TP-Link I have a 200 mbps fibre connection. It works perfectly for a while, and then the speed goes down to 10mbps until I reboot my main deco. Rebooting immediately fixes the problem, but it always returns after a day or so.

  0  
  0  
#4
Options
Re:Deco x20 connection speed drops
2021-09-03 06:49:18
Ps. When the speed drops, it is for both wired and wifi connected devices on the deco network
  0  
  0  
#5
Options
Re:Deco x20 connection speed drops
2021-09-06 11:16:49

@Fr0stY 

Hi, Thank you for the update.

When the speed dropped to 10m/s, if testing speed via speedtest on the APP, what is the current speed?

If taking out the main deco and connecting to PC via cable to the modem, how much speed on the laptop?

May I know who is your internet service provider and what is the model number of the ISP cable modem?

Please also refer to the following suggestions:

1. Change a new Deco as the main Deco:How to Setup the Satellite Deco to be the Main Deco?

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#6
Options
Re:Deco x20 connection speed drops
2021-09-06 11:27:13

@Fr0stY 


Solution that worked for me:

Connect 1 of the unit directly to your ISP router via LAN cable. 

 

This means that you'd have to sacrifice one of your mesh unit to be situated right beside the router. But it worked for me. No more speed drops. 

 

  0  
  0  
#7
Options