Unable to access Github.com from behind Deco x60

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Unable to access Github.com from behind Deco x60
Unable to access Github.com from behind Deco x60
2020-11-29 05:49:07 - last edited 2020-12-02 20:17:19
Model: Deco X60  
Hardware Version: V1
Firmware Version: X60(1.0) 1.2.6 Build 20201013 Rel. 57035

I am unable to access github.com at all from behind the Deco x60.  But if I disconnect my phone or computer from the Deco's WiFi and connect them directly to the WiFi of my Xfinity XFi modem router, then I can access github.com.  The Deco is behind the XFi modem router.  Both the Deco and the XFi modem operate as routers, each broadcasting its own WiFi networks.  I rebooted all 3 Decos without avail. 

 

DNS is not the problem because the github.com name resolves to the correct IP address when I am behind the Decos.  Ping request to github.com times out however. 

 

If I use VPN on my computer, then I can access github.com from behind the Deco.

 

On the Deco, parental control and antivirus features are all off.

 

I have this problem only with github.com at this point.

 

Please help.  Thanks.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Unable to access Github.com from behind Deco x60-Solution
2020-12-02 18:24:38 - last edited 2020-12-02 20:17:19

@Rocket20 

 

Since the VPN is not using the Deco DNS, I would then change whatever DNS is set in the Deco WAN port to something like 8.8.8.8 and 8.8.4.4. Another thing to possibly try is to see the Deco as an access point since it is connecting to a router already.

Recommended Solution
  1  
  1  
#2
Options
5 Reply
Re:Unable to access Github.com from behind Deco x60-Solution
2020-12-02 18:24:38 - last edited 2020-12-02 20:17:19

@Rocket20 

 

Since the VPN is not using the Deco DNS, I would then change whatever DNS is set in the Deco WAN port to something like 8.8.8.8 and 8.8.4.4. Another thing to possibly try is to see the Deco as an access point since it is connecting to a router already.

Recommended Solution
  1  
  1  
#2
Options
Re:Unable to access Github.com from behind Deco x60
2020-12-02 20:16:58

@Tony Thanks.  I set the Deco x60 to Access Point Mode (turning off its routing features) and relies on the xFi router for routing instead.  That worked.  

  0  
  0  
#3
Options
Re:Unable to access Github.com from behind Deco x60
2021-11-05 17:58:21 - last edited 2021-11-05 18:01:35

@Tony I am facing the same issue when trying to ssh to Github.com but do not want to resort to turning off the routing features of my Deco x20 - what could be the root cause of such an issue and how could it be resolved properly? Is the Deco default to preventing outgoing requests to port 22?

 

  0  
  0  
#5
Options
Re:Unable to access Github.com from behind Deco x60
2021-11-08 09:11:42

@Meshed75 

Hi, both our Home routers and Deco did not support SSH log-in and port 22 is reserved for Tether/Deco APP.

Thank you.

  0  
  0  
#6
Options
Re:Unable to access Github.com from behind Deco x60
2021-11-08 11:28:51 - last edited 2021-11-08 11:29:08

@TP-Link

 

Thanks @Tony. I only have a Deco x20 router since my Broadband router is set to modem-only mode. I was not trying to ssh into the Deco itself, simply open an ssh connection to github.com. I fixed the problem by switching my DNS settings from Virgin Media's to Cloudflare (1.1.1.1 and 1.0.0.1). That immediately allowed me to connect via ssh to github.com. Thanks for the assistance.

  2  
  2  
#7
Options

Information

Helpful: 0

Views: 759

Replies: 5

Related Articles