Deco M9 Plus inconsistent speed after firmware update to 1.5.0

Deco M9 Plus inconsistent speed after firmware update to 1.5.0
Deco M9 Plus inconsistent speed after firmware update to 1.5.0
2021-02-24 21:52:09
Hardware Version:
Firmware Version: 1.5.0 Build 20201211 Rel. 42330

I saw that there was an US firmware update avaliable on the site, and I decide to update my Deco from 1.4.3 Build 20200921 Rel. 42500 to 1.5.0 Build 20201211 Rel. 42330 following the PDF instruction.  After updating using the update program, my app shown that the version was still 1.4.3 Build 20200921 Rel. 42500.  This was odd, so I use https://tplinkdeco.net/ to check, and saw that only the main Deco was not updated.  So I did a local update using the site, and it update all three.  But now after all 3 Deco was update to 1.5.0, I see that my speed is inconsident.  Before, I was consistently getting about 311mbps/11mbps wired.   But my last 3 ran SpeedTest gave me 176mbps, 314mbps, and 78mbps.  Also whenver I use https://tplinkdeco.net/, it keeps giving me a Operation failed message, and does not show my WIFI information.  I haven't touch the any of the app settings. 

 

Is there a problem with this firmware?

0
0
#1
Options
7 Reply
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
2021-02-26 23:06:21

@andrewl923 

 

The v1 and v2 M9s got another release (1.5.1). For the v1 it is on our site, but not the v2 yet. I would try that release then retest the speeds to see if you are still getting the same issue.

0
0
#2
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
2021-02-27 00:18:11

@Tony 

 

I see that a V2 firmware of Deco M9 Plus(US)_V2_1.5.1_210126 is located at V1 firmware selection screen.  Can I use that for my V2?

0
0
#3
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
2021-03-01 17:24:42

@andrewl923 

 

That is in the incorrect section, I'll see about correcting that. In the meantime, yes, you can grab the v2 there.

0
0
#4
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
Thursday

@andrewl923 

I have also experience inconsistent internet speeds. Range is also horrible after updating to Deco M9 Plus(US)_V2_1.5.1_210126 firmare.

I have 800mps internet, wired to deco does get good speeds but wifi drops significantly.

I know there are limitations with wireless and I am not expecting getting the same speed but if I speed test in the room next door my speed goes to less than 100 mbps, my house has thin walls, even if I open the door and test in the hallway I get really slow and inconsistent speeds. It used to work very good before this update.

2 rooms away from the router I get about 20mbps, unacceptable.

I was thinking on getting the new deco to solve this problem but something tells me this is a firmware issue.

0
0
#5
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
Friday

@brocardo 

Hi, It might be too earlier to say the firmware is guilty, and could you please help me check the following information.

Since there are 3*M9, could you please check each satellite has at least 2 bars for the wireless backhaul strengthen?

Could you please send me a picture of the network topology, such as:

 

When you run the speed test, was the device connected to the main Deco all the time? via 5ghz?

And have you checked the link speed on the devices when the speeds were about 100m/s and 20m/s?

Thank you very much.

0
0
#6
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
Friday

@TP-Link 

 

Here is my topology.

I am not sure how to check for the deco strenght. The ones in the second floor are maybe 30ft apart.

I am assuming my phone is connected to the 5Ghz channel when testing the speed. I have the deco wifi enabled for both 2.4 and 5. They auto switch right? That was my understanding

 

0
0
#7
Options
Re:Deco M9 Plus inconsistent speed after firmware update to 1.5.0
14 hours ago

@brocardo 

Hi, please refer to this picture to check the signal source:

Could you please turn off the 5Ghz on the main network on the APP and test the speed again?

If the speed is still around 100m/s, please help me check the link speed as well:

How to check the associated/link speed on a wireless client

0
0
#8
Options