Device GUI unreachable after setting subnet to 255.0.0.0

Device GUI unreachable after setting subnet to 255.0.0.0
Device GUI unreachable after setting subnet to 255.0.0.0
2021-07-08 16:50:28
Hardware Version: V1
Firmware Version: 1.1.5 Build 20201230 Rel. 40557(5553)

[Description]

When setting a new network address and changing the subnet in the advanced settings, if it is set to 255.0.0.0 without using the "custom" option but the "255.0.0.0" in the drop down menu, the web management GUI is not reachable and cannot be pinged/nmap shows no 80 port open/host down.

 

[Steps to reproduce]

1) Follow standard setup all of the way through until it brings you to the home page of the web GUI.

2) Go to advanced settings and then select the LAN sub menu in the network menu.

3) Change the ip to 10.0.0.1 and choose the subnet 255.0.0.0 with its option, not inputting it manually using the "custom" option.

4) Let the device save the settings.

5) Set a static ip of 10.0.0.2 with a 255.0.0.0 subnet.

6) Try connecting with either 10.0.0.1 or the tplinkwifi.net to connect to the web GUI.

 

[Standard setup used]

Timezone: Pacific time

WAN: No

Wifi radios: Disabled *have tried with enabled but showed no difference

 

[Expected results]

The web GUI should open to its home page and allow for normal operations.

 

[Actual results]

The page gives "Unable to connect" error, it does not matter if it is the 10.0.0.1 or tplinkwifi.net for the address entered in the browser. Ping results give "Network is unreachable" and nmap shows "Host seems down".

 

[Times seen]

 

5/5 times I tested using the repro steps I was able to see the same issue.

 

[Additional info]

 

OS: Linux Manjaro

Version: 5.10.31-1-MANJARO

 

Connection: Ethernet cable Cat5e

Network card/manufacturer: Qualcomm Atheros QCA8171 Gigabit Ethernet REV 10

 

Browser: Firefox

Version: 88.0.1

Build: 20210506154205

 

*I have tried disabling the DHCP server before setting the ip/subnet and it does not show any differences

 

*I was able to set it up correctly if I set the subnet with the "custom" option, still setting it with the same ip/subnet, just not if you use the "255.0.0.0" option.

 

0
0
#1
Options
2 Reply
Re:Device GUI unreachable after setting subnet to 255.0.0.0
2021-07-20 21:13:33
Just curious why on earth you would create a class A network at 10. subnet? Sure, it shouldn't break the router but I can't imagine any situation where that would be anything but an awful decision - do you understand what that means? That you're going to have a network capable of tens of thousands of devices on ONE subnet with ALL broadcast traffic hitting every single device. So curious as to why you'd do something so far out of any recommended setup? Not trying to be rude but I can't imagine any possible way that's a good idea, am I missing something???
0
0
#2
Options
Re:Device GUI unreachable after setting subnet to 255.0.0.0
2021-07-20 21:46:20

@RossCarlson, I understand your confusion, I was just playing around with settings and testing different things and just thought it was weird that it locked up. It also has been a while since I have calculated subnet and I forgot that it could get that drastic. I appreciate you asking anyways, I think it is a good point though, most consumers won't be trying to do that unless it's by accident. Thanks for your time,

0
0
#3
Options