Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding

Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-26 01:38:58 - last edited 2021-09-29 01:30:00
Model: Deco X20
Hardware Version: V1
Firmware Version: 1.5.1 Build 20210204 Rl. 50738

I have an older client, HAI Omni Pro II security system controller, that uses a static ip address that I can configure.  I set the ip in the range set on my Deco system. I have 6 Deco X20 Mesh WiFi devices with a main device set up as a router and connected directly to a Spectrum cable modem and 5 satellite Deco devices around the building.  Some of the satellites are connected to Ethernet and some are on WiFi.  There are some switches in the system as it is a large building and the Ethernet network was added to over time during renovations, etc. For most everything I use (computers, phones, printer, Smart TV's, Tablets, etc.), this has all worked great. 

 

The Omni has always been connected to the Ethernet network via a switch.  When I was using Apple's Airport equipment for my network, I had no problem setting up an address reservation and port forwarding. I can ping the Omni from terminal on my Mac successfully so I know it is on the network.  Even after switching to Deco, the Omni is on the network as indicated by successful ping on terminal.

 

For the Omni, I have been unable to get it to show up on the client list on the Deco app.  I need to set an address reservation and port forwarding for it so I can connect to it from the phone app that allows me to control the various features it provides.  In the Deco app, if its not on the client list, I can not do any configuring.  Frustrating. 

 

Today, I spent over an hour on an online chat with TPLink going through a number of things to try to get the client to show on the Deco App.  This included moving a satellite Deco near the client and connecting it directly to the Deco's Ethernet port with the Deco connected to the network via Ethernet, and then WiFi.  With the satellite Deco connected to the Ethernet switch on port 1 and the Omni connected to Ethernet port 2 on Deco, I can ping the Omni form terminal.  When the Deco is using WiFi, and I connect the Omni to it, I can not ping the Omni in terminal.

 

TPLink put in a ticket to get an engineer to help me.  That will not be for another couple of days ("within 1 business day" responses always happen on Saturday morning...).

 

My only thought is to go back to using the Airport Extreme as the Router (or a different router) and just use the Deco's to provide the WiFi.

 

Any thoughts?

 

Thanks!!

0
0
#1
Options
2 Accepted Solutions
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding -Solution
2021-09-28 18:53:25 - last edited 2021-09-29 01:30:00

I have a suggestion, a different way to get where you're trying to go with the Omni. Pick some arbitrary device on your LAN and give it the static address that you could give to the Omni when we get done. Forward the proper port of that new static address. Shut down the arbitrary device for a moment. Change the Omni to the static address you selected. The Omni should now be on the address and the port will be forwarded through the Deco. I would allow the old device's lease to expire before bringing it back online.

Recommended Solution
2
2
#7
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding -Solution
2021-09-28 19:33:28 - last edited 2021-09-29 01:30:05

@GitchiGummi That suggestion worked!! 

 

I had forwarded teh port at a given address for a router that I  was trying to use to get this to work on a dual router set-up (that idea failed).  I assigned that ip to the Omni panel and suddenlt the app I use to access Omni was working!  And, I could see the Omni on the mail client list of the Deco app.  But, I could not see the Omni on the Deco list when attempting to assign an address reservatino. 

 

After re-starting the Deco app, the Omni also showed up on the list to reserve an address in the Deco app. and I was able to reserve that address. So, all is good now.  Thank you!

Recommended Solution
2
2
#9
Options
9 Reply
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-26 07:09:30

@GitchiGummi 

Hi, Have you tried to set up HAI Omni Pro II security system controller to get an IP address automatically and check whether it shows up?

If yes, we could set up an address reservation under Dynamic IP to fix the IP.

I also see that your case has been forwarded to the senior engineers already and please check the email for further assistance.

 

Thank you very much.

0
0
#2
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-26 13:43:21

@TP-Link Unfortunately, the Omni only supports a static ip setup, it does not support dynamic ip protocols. 

2
2
#3
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-28 01:55:12

@GitchiGummi 

Hi, thank you for the time and patience.

In this way, could you please send me some screenshots of the static IP configuration on the HAI Omni Pro II security system controller?

Please make sure except for the IP address, you have also put the Gateway, DNS server.

 

 

0
0
#4
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-28 13:27:40

@GitchiGummi The Omni is programmed with an ip address in the standard format using a control panel.  I am not able to configure any additional network parameters.  So, it has a static ip address, as I have stated, and the other parameters you have asked about are not configurable.

0
0
#5
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-28 15:57:11
0
0
#6
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding -Solution
2021-09-28 18:53:25 - last edited 2021-09-29 01:30:00

I have a suggestion, a different way to get where you're trying to go with the Omni. Pick some arbitrary device on your LAN and give it the static address that you could give to the Omni when we get done. Forward the proper port of that new static address. Shut down the arbitrary device for a moment. Change the Omni to the static address you selected. The Omni should now be on the address and the port will be forwarded through the Deco. I would allow the old device's lease to expire before bringing it back online.

Recommended Solution
2
2
#7
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-28 19:05:21

@Don.M Thank you. I will try that.  i think I can get Port Forwarding set that way, but not Address reservations. The Deco app lists the MAC address of the Client as well as the ip in the Address Reservation section.  If MAC addresses do not match, will Deco still "recognize" the device and route traffic to it? 

0
0
#8
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding -Solution
2021-09-28 19:33:28 - last edited 2021-09-29 01:30:05

@GitchiGummi That suggestion worked!! 

 

I had forwarded teh port at a given address for a router that I  was trying to use to get this to work on a dual router set-up (that idea failed).  I assigned that ip to the Omni panel and suddenlt the app I use to access Omni was working!  And, I could see the Omni on the mail client list of the Deco app.  But, I could not see the Omni on the Deco list when attempting to assign an address reservatino. 

 

After re-starting the Deco app, the Omni also showed up on the list to reserve an address in the Deco app. and I was able to reserve that address. So, all is good now.  Thank you!

Recommended Solution
2
2
#9
Options
Re:Client With Static ip Not on Client List on Deco App, No Address Reservation or Port Forwarding
2021-09-29 17:04:12

@GitchiGummi Just to be clear, if you have a device with a static ip address that you cannot see or set up in Deco and you want to configure port forwarding and an address reservation for it:

 

1) Connect a temporary device/client to the Deco network that can accept an assigned address.  I used an Apple Airport Extreme Router in a Lan to Lan configuration.  I think almost any client would work for this step.  I used Ethernet, perhaps wireless would work as well.

2) Using the advanced menu in the Deco application, Port Forwarding, Internal IP, Select From Device: set port forwarding to that device using the assigned address, and the appropriate port number(s) for the static ip device you are trying to set up.

3) Unplug or disconnect the device you assigned port forwarding for from the network.  The port forwarding setting will remain in the Deco application.

4) Assign the ip address that you forwarded to your device that accepts an assigned static ip.  Make certain the port is set correctly, as well, if configurable.

5) In my case, this step led to being able to use the app that controls the static ip device.  It was connected to teh network!

6) I had to re-start the Deco app to get the static ip device to show on the list of choices for Address Reservations.

6) Set an Address Reservation in the Deco application for the device with the static ip using the Advanced, Address Reservations menus.

2
2
#10
Options