how do i use a DNS server on my local network

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
how do i use a DNS server on my local network
how do i use a DNS server on my local network
2021-10-10 08:44:06
Model: Deco M5
Hardware Version: V7
Firmware Version:

Hi,

 

I use a Pi as a DNS server at home. When I pointed to it, the deo changed the IP range all of a sudden from 192.168.0.0 to 192.168.1.0.

 

When I tru to point to the DNS server now it says "DNS server IP address and LAN IP address cannot be in the same subnet."

 

Please help

 

A

0
0
#1
Options
4 Reply
Re:how do i use a DNS server on my local network
2021-10-11 06:31:28

@Ducks 

Hi, did you enable the guest network?

If not, please go to Deco APP>More>Advanced>DHCP server and put the Pi address here.

Thank you very much.

0
0
#2
Options
Re:how do i use a DNS server on my local network
2021-10-11 06:40:55

@TP-Link 

 

Thank you, but can you please be more specific? I do have a guest network enabled, but how does that impact?

 

In the DHCP, where would I put the PI ip? In the DNS setting?

0
0
#3
Options
Re:how do i use a DNS server on my local network
2021-10-11 07:12:59

@Ducks 

Hi, please refer to the attached picture.

As for the guest network, when you put Pi-hole as LAN DNS server which might cause guest network no internet service since Pi-hole belongs to the main network.

0
0
#4
Options
Re:how do i use a DNS server on my local network
2021-10-11 16:31:45

I also have a Pi as my network DNS server. (My Deco M9 Plus is attached to an ATT Arris BGW210 router). Sometimes my Deco accepted the Pi on the LAN, and then other times it balked and changed the network address (192.168.10.x, 192.168.68.x). I finally got it sorted out. What I've done is:

  • Set the Pi as DHCP server and DNS server.
  • Give the Pi a static address (it won't assign itself one via DHCP. I chose192.168.0.2).
  • DIsable the DHCP (and wifi) in the BGW210.
  • Make the Deco mode AP, not router
  • Have the Pi DHCP use the range 192.168.0.100 - 192.168.0.200, gateway 192.168.0.254. When I first set it up, I chose a very short DNS lease (1 hour), after things looked stable I changed that to 24 hours.

 

My network now uses 192.168.0.0 - 192.168.0.255. The BGW210 is x.x.x.254, the Decos are x.x.x.1 and x.x.x.3, the Pi is x.x.x.2. (I used static settings in the Pi to assign the Decos and several other devices that I SSH into. Other Pi's are at x.6, x.12. In all, I have 12 static assignments in the Pi DHCP settings).

 

2
2
#5
Options