X20 Ethernet speed slow by half

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
X20 Ethernet speed slow by half
X20 Ethernet speed slow by half
2022-01-23 22:03:48
Model: Deco X20  
Hardware Version:
Firmware Version: 1.5 Build 20210204 Rel. 50738

I have the Deco X20 but I am not seeing the close to the max DL speed for my 1GB up and 1GB down internet.

 

Speed test in the deco app confirms 909 Mbps Down and 987 MbPs Up.  Pefect.

 

Ethernet cable straght out of a deco satelite gets me 505 Mbps down (not so good) and 869 Mbps Up (Perfect).

 

I have tried:

 

  • Switching cables
  • Factory reset
  • AP Mode
  • QOS various settings
  • Turning UPNP on and off
  • Switching devices out of the deco (different switches, different laptops).  Same restult always half of the DL speed I am looking for.
  • latest firmware
  • using different Deco satelites, using just one satelite and just one laptop (nothing else connected to network)


I have searched the internet and I am throwing in the towel.  I hate to buy a new router but it shouldn't be this complicated....

 

Any thoughts?

 

 

 

  0      
  0      
#1
Options
1 Reply
Re:X20 Ethernet speed slow by half
2022-01-24 07:36:46

@gunner23_98 

Hi, may I know how many Deco units do you have? And Are they connected via Ethernet cables?

If they are connected via Ethernet cable, how far away from each other, and are they on the same floor?

Could you please provide me a layout about your network setup, such as:

ISP modem router---main Deco X20—switch---<wired>---satellite Deco X20

  0  
  0  
#2
Options