Deco M4 not assigning DHCP IP addresses to any Raspberry I got

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco M4 not assigning DHCP IP addresses to any Raspberry I got

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M4 not assigning DHCP IP addresses to any Raspberry I got
Deco M4 not assigning DHCP IP addresses to any Raspberry I got
2022-04-08 08:17:39 - last edited 2022-04-08 08:41:35

Hello,

 

I've been having this problem regarding connection with my raspberry pi 3B and now with a Pi400 I got just yesterday.

 

No matter if the Deco is setup as a router or a point access, it doesn't allow for an IP to be assigned to the raspberry. It stops it somehow and this happens through WIFI and Ethernet too, for my surprise.

 

Normally I have the WIFI of my regular router turned off to not interfere with Deco's, but yesterday to test it out I enabled wifi there and the raspberries got their IPs instantly.

 

I've read in some other posts that having static IP works, but it's Linux what we are talking about, so it's basically a pain in the ass to do that and I don't think I have to overcomplicate my existence when DHCP should work fine out of the box. Every other piece of hardware I own (laptops, Pc's, smartphones, consoles) connect perfectly well to the Deco so there must be something different about the way the pi asks for an address or something, idk.

 

Is there any option I might be missing? What can I do?

  2      
  2      
#1
Options
3 Reply
Re:Deco M4 not assigning DHCP IP addresses to any Raspberry I got
2022-04-12 09:55:42

  @KamE_AleX 

Thank you very much for the feedback and Do you still have the same issue on raspberry Pis?

I am not sure what might be the problem and if you would like to spend a little more time, I would like to forward your case to the senior engineers.

At the same time, there are some basic suggestions for your reference:

1. please check the Blacklist under Deco APP>More and make sure no device is here.

2. if possible, please unplug the satellite Deco M4S, and leave the main M4 only; then connect Pi400 again to see whether there would be any difference.

Best regards.

 

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  0  
  0  
#2
Options
Re:Deco M4 not assigning DHCP IP addresses to any Raspberry I got
2022-04-12 10:03:10 - last edited 2022-04-12 10:03:55

  @David-TP I solved it in a very strange way. I'll tell you the whole story, just in case it's of some value for your team.

 

Desperate as I was, I tried a couple things. First I turned on my main router's Wifi and set a very simple password to test. The raspberry connected, no problem.

After that test, I set up a guest network in the Deco app. No password at all, no security, all open. The raspberry connected there too.

So I was back to the main Deco connection and failed to connect. I checked several times every single thing and then I thought: ok, what if my password (what was something comparable to MonkeyIsland@4321) is the problem? So I changed it to a simplier one, just MonkeyIsland. And it connected flawlessly.

 

The curious thing is that the long password works on my router, but not with the Deco for just specific pieces of hardware. Why? Don't know. Laptops connect well, consoles too, smartphones, everything. But for some reason, raspberry (any software you install on it so I'd say it's Linux in general) fails to connect to the Deco when the password is like that.

 

Weird? Sure.

 

Thanks for your help anyway!

  2  
  2  
#3
Options
Re:Deco M4 not assigning DHCP IP addresses to any Raspberry I got
2022-04-12 11:43:05

  @KamE_AleX 

Thank you very much for the update and I am glad to know you have fixed this issue now.

I did remember I had seen similar feedback before on different devices so far the possible cause is still not clear.

I will note down this case for further records maybe it could provide some guidance next time.

Thank you again.

Best regards.

Wi-Fi 7 Launch Replay: https://www.tp-link.com/us/wifi7/event | Leave me a message with any Urgent Requests, or Simply Feel Left Out
  1  
  1  
#4
Options