Archer T9UH v2 - Only connects at 600mbps

Archer T9UH v2 - Only connects at 600mbps

Archer T9UH v2 - Only connects at 600mbps
Archer T9UH v2 - Only connects at 600mbps
2022-08-23 21:53:41
Model: Archer T9UH  
Hardware Version: V2
Firmware Version:

Hello - 

 

I've had a few disconnects and also I have speed concerns. I expected this to connect to my TP Link Wireless Router (TP-Link AC5400) at something better than 600mbps. The router is in the very next room (very close, just the other side of the wall). 

 

I could swear it used to connect faster than this. I have no explanation for the change. Any recommendations for what I should do?

 

(I did use the drivers posted on the TP Link site for Windows 10 x64)

  0      
  0      
#1
Options
2 Reply
Re:Archer T9UH v2 - Only connects at 600mbps
2022-08-24 22:46:32

  @dawnbreaker09 

 

There are several factors that affect network speeds.  

 

  • distance from router
  • link rate
  • number of antennas
  • antenna configurations for instance  1x1, 2x2, 3x3, etc.
  • Band and band throughput rate

 

We would need to know more to say if the 600 Mbps is good but generally speaking it sounds like about right in most cases. 

Hi, Wi-Fi 7 | TP-Link Wi-Fi 7 Product Launch Event | November 14, 2022 @ 10:00AMPST Watch Live At: https://www.tp-link.com/us/wifi7/event/
  0  
  0  
#2
Options
Re:Archer T9UH v2 - Only connects at 600mbps
Tuesday
My internet download speed is 200mbps. When using the original drivers that were on the CD, I reached a download speed of 217. However, when I installed the latest drivers, my download speed was 145mbps. I uninstalled the drivers and installed the drivers from the CD, my download speed returned to 200mbps. I don't know what the current drivers are, but this incident happened about 4 months ago. You should check your speed at speedtest.net and test the original drivers and latter drivers.
  0  
  0  
#3
Options