X60 won't connect to Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

X60 won't connect to Internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
X60 won't connect to Internet
X60 won't connect to Internet
2022-12-17 15:49:47 - last edited 2023-01-03 11:31:31
Model: Deco X60  
Hardware Version: V7
Firmware Version: new

Radio internet. Verified signal and connections. Tried power cycling radio after Deco is connected. Still no joy. It will not connect to the internet. ISP does not require MAC address.

  0      
  0      
#1
Options
1 Accepted Solution
Re:X60 won't connect to Internet-Solution
2022-12-19 14:34:30 - last edited 2023-01-03 11:31:31

  @David-TP Thank you for your reply. I was finally able to get hold of my ISP as well. My previous ISP sold to a new company and it turns out that the new ISP requires MAC ID registration of all routers. Problem solved.

Recommended Solution
  3  
  3  
#3
Options
2 Reply
Re:X60 won't connect to Internet
2022-12-19 07:12:31

  @tsp_chey 

Good day,

May I know who is your internet service provider?

And Did the main Deco X60 turn to solid red as well?

If you go to Deco APP>More>Internet connection IPV4, would there be a valid IPV4 address?

Wait for your reply.

Best regards.

  0  
  0  
#2
Options
Re:X60 won't connect to Internet-Solution
2022-12-19 14:34:30 - last edited 2023-01-03 11:31:31

  @David-TP Thank you for your reply. I was finally able to get hold of my ISP as well. My previous ISP sold to a new company and it turns out that the new ISP requires MAC ID registration of all routers. Problem solved.

Recommended Solution
  3  
  3  
#3
Options

Information

Helpful: 0

Views: 426

Replies: 2

Related Articles