Own DNS server doesn't function when second (external) DNS server is configured

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Own DNS server doesn't function when second (external) DNS server is configured

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Own DNS server doesn't function when second (external) DNS server is configured
Own DNS server doesn't function when second (external) DNS server is configured
2023-08-05 19:50:40 - last edited 2023-08-05 19:51:47
Tags: #DNS
Model: Deco X50  
Hardware Version: V1
Firmware Version: 1.2.5

I have a Raspberry Pi with Pi-Hole running in my network and successfully configured it as primary DNS server in DHCP Server settings on my X50. Besides add-blocking, I use the Pi-Hole to configure a couple of local DNS records (for example portainer.home, kodi.home, nas.home). Everything works as expected and the local domains can be reached successfully. 

 

Now, I want to configure a secondary DNS server in the X50 in case my Raspberry Pi and/or Pi-Hole for some reason don't function. However, as soon as I configure a secondary DNS in DHCP Server settings (1.1.1.1, 8.8.8.8, or some other external DNS), I cannot reach my local domains anymore (DNS_PROBE_FINISHED_NXDOMAIN). As if the primary DNS server is not accessed anymore and only the secondary one is used. 

 

Anyone has any thoughts on what's going on and how to solve this? 

  3      
  3      
#1
Options
2 Reply
Re:Own DNS server doesn't function when second (external) DNS server is configured
2023-08-07 03:34:12

  @BjRnJ 

Hi, welcome to the community.

Are you able to stably reproduce this issue?

Have you checked the IP settings on the clients to see what are the current DNS servers?

It is also suggested to only leave the Pi-Hole as the local DNS under DHCP, then leaves 1.1.1.1 or 8.8.8.8 as the WAN DNS server here:

How to change DNS server settings on my Deco

 

Thank you very much.

Best regards.

 

  0  
  0  
#2
Options
Re:Own DNS server doesn't function when second (external) DNS server is configured
2023-08-07 15:32:37

  @David-TP 

Thank you for the quick response. 

 

I was able to stably reproduce the issue by following the configuration steps described in my first post. I've done so at least 20 times spread over the last 6 months with the same result every time, often testing on multiple devices. I just followed the same configuration steps again (Pi-Hole as primary, external as secondary DNS) to check the current DNS server(s) used by my devices as you suggested: both Pi-Hole and external DNS were available to my devices. After checking this, I validated if the local domains were still inaccessible. However, for some magic reason I now can reach them for the first time while configuring both DNS servers. Have you guys worked magic today, or is this just coincidence? ;)

  0  
  0  
#3
Options

Information

Helpful: 3

Views: 266

Replies: 2

Tags

DNS
Related Articles