KL400L5 Light Strip disconnects

KL400L5 Light Strip disconnects

KL400L5 Light Strip disconnects
KL400L5 Light Strip disconnects
2022-05-15 17:56:20
Model: KL430  
Hardware Version: V1
Firmware Version: 1.0.8

I have the KL400L5 light strip and I'm using the Kasa app on my phone to control the lights. I chose the model of KL430 for the bug report since that is the closest I could find. Sometimes the App will disconnect from the lights, it will no longer be able to control them. If I wait about a minute then it will come back. I have checked my wifi strength and it looks good. The light strip is about 6' from my Deco M5 wifi hot spot. I also put a constant ping on the light strip to verify it did not lose connectivity and it does not. I also tried to control this light strip with my Home Assistant server. It does the same thing, I can control it sometimes but then the HA server reports the light strip 'became unavailable'. But after about a minute it comes back. I'm assuming this is a bug with the firmware of the light strip.

  0      
  0      
#1
Options
29 Reply
Re:KL400L5 Light Strip disconnects
2022-05-16 01:43:33 - last edited 2022-05-17 05:30:24

  @Jethro65 

Thank you for starting a bug report!

1.  Please check does smart device work in the local network when issue occurs? Or when the issue occurs, can you still ping the smart device successfully? 

When the issue occurs, connect your mobile device to the home Wi-Fi network at that time and see if Kasa device is still accessible in the local network?

2. Try to turn off Fast roaming on Deco for smart device

3. Try to create a Guest wifi network (turn off 5Ghz) and connect smart device to 2.4Ghz guest network and test stability

 

If still the same, can you help confirm case details here:

1.a photo of Error message on the Kasa APP

A photo of ping result 

2. the network topology:

e.g. ISP Spectrum-main Deco <Wireless>Deco #2 <Wireless> Kasa device

3. How often does the issue happen, and how does the recover the connection, like reboot smart plug or reboot router? 

 

 

 

 

  0  
  0  
#2
Options
Re:KL400L5 Light Strip disconnects
2022-05-16 22:59:30

Both the smart light and mobile phone is on the same local network when the problem happens. At first when the problem happened I was still able to ping the smart device when it disconnected from the app on the mobile phone. But as I tested more often I noticed the pings would stop when the problem happened.

 

Fast Roaming was already off and the Mesh Technology was off for the smart device in the Deco App. I turned off 5G so both the smart device and mobile phone was on 2.4G. The problem continued to occur.

 

Normally the smart device will come back after a minute or two. But at least once it did not come back after 5 minutes. It was not ping-able. The smart light was on and I couldn’t even turn it off with the physical button on the smart light controller. At this point I decided to do a factory reset and put the smart light and mobile phone on the guest network with only 2.4G enabled as you suggested.

 

I removed the smart light from the App then held the button in for 10 seconds to initiate a factory reset. I re-added the smart device and connected to the guest network. At this point the smart device appeared to be working correctly. But after about 15 minutes it lost connectivity and the pings stopped. The smart light was on and I couldn’t turn it off with either the mobile app or the physical button on the smart light. I left the smart device alone for 5 minutes but it never came back. I power cycled the smart light and it started working again. After the factory reset and putting in on the guest network with only 2.4G enabled, the device seems to be working better but it is still having disconnects.

 

Attached is the photos/screenshots you requested along with a diagram of my network. More than half the time the smart light will recover on its own after about a minute. But sometimes I have to power cycle the smart light. Twice it got stuck turned on and it never came back. A power cycle fixed it. I did notice that after a factory reset it does work better (I’ve done that twice) but will eventually degrade.

 

Thanks,

Jeff

865bef29aaa74867b964023d46da0f54fa9ff16bd1d644bdb7bc53ddcaeab692941bcb08fb664c76bc89e2c63ed5640884fcc50d3b8149cd949e7057f6cedb63

  3  
  3  
#3
Options
Re:KL400L5 Light Strip disconnects
2022-05-17 06:32:41

 Hello  @Jethro65 

Thank you for more case details, it is unusual if you can't physically turn off the smart strip, from the description it could be some defect on the unit, we would like to follow up your case via support email to check warranty, please check your email inbox TKID220518001. 

 If you have any old router or AP, try to connect it to a different AP and check stability. 

 

  0  
  0  
#4
Options
Re:KL400L5 Light Strip disconnects
2022-05-17 21:09:03

  @Solla-topee Unfortunately I do not have an old router or AP to test with. The smart light strip is registered under my TP Link account and shows it is under warranty. Thanks for all your help.

 

Jeff

  0  
  0  
#5
Options
Re:KL400L5 Light Strip disconnects
2022-07-03 17:00:33

  @Jethro65 

 

I'd like to add that I have two of these KL400L5 LED light strips. They both act the same as Jeff described above. They lose connection. They reconnect and work for a minute or two and fail again. Many times I come home and the LED strip one of them is on with nobody requesting it to turn on. 

 

I now have them powered down as they don't work.

 

Please fix and provide firmware update.

 

Dennis

  1  
  1  
#6
Options
Re:KL400L5 Light Strip disconnects
2022-07-04 02:08:44

Hello   @DK55 

Thank you for the feedback, can you start a new thread with case details like the error message, model of router, frequency etc, and we'd like to look into that further. 

When an issue occurs, please check smart device work in the local network?

For a test, connect your mobile device to the home Wi-Fi network at that time and see if Kasa device is still accessible in the local network?

For the Kl400 turns itself ON, it is recommended to check if there is any power outage as kasa bulb/ light strip will turn on after a power outage by default. 

 

  0  
  0  
#7
Options
Re:KL400L5 Light Strip disconnects
2022-09-12 21:39:45

I have 5 KL400l5s, EVERY SINGLE ONE of them drops out, I have tried away from the router, close to it, on top of the router, nothing stays consistent. 

 

REALLY unhappy with these. My entire house has all the switches with TPLink, but these? Miserable.

  4  
  4  
#8
Options
Re:KL400L5 Light Strip disconnects
2022-09-15 01:58:37

I have exactly the same issue. Can you please provide a fix?

 

  1  
  1  
#9
Options
Re:KL400L5 Light Strip disconnects
2022-10-18 03:35:20

  @Jethro65 Same problem here! I have all Kasa smart switches and they work flawless. However, these LED light strips are not reliable at all. They constantly disconnect from the network.

  0  
  0  
#10
Options
Re:KL400L5 Light Strip disconnects
2022-10-19 03:55:47

  @Jethro65 Was there ever a fix for this?

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 3669

Replies: 29