How to set up Ethernet Backhaul with your Deco devices
Re:Re:Re:How to set up Ethernet Backhaul with your Deco devices
2019-04-30 21:36:20

Thank you for that tip! I will try that and report back. Just to confirm: You're using them in Access Point mode?  And the simple switch was or was not connected to the internet?
 

Thanks!
Chris

0
0
#130
Options
Re:Re:Re:Re:How to set up Ethernet Backhaul with your Deco devices
2019-05-01 04:23:05 - last edited 2019-05-02 14:57:18

Update: Here is my procedure for getting (I think/assume) Ethernet backhaul to work with the Deco M9 in Access Point mode. This requires a non-DLink switch. It may require all Decos to be communicating directly on the same switch. 

 

A: It appears I have managed to make everything happy but it is definitely finicky, for a few reasons. Hopefully the explanation below helps.

 

B: I started by first resetting the 4 Decos so they were all in blue-flashing light setup mode.

 

C: i also reset my ISPs router/switch so that it was fresh by unplugging/replugging the router. (You need to do this everytime something breaks!)

 

D: I then plugged them all into a simple switch that itself was *disconnected from the internet.

 

E: It was a Netgear brand switch. This probably matters. A D-Link branded switch may not work more on that later.

 

F: As the two ports on the Decos are not marked, I used the port nearest the power to plug into the switch for each Deco.

 

G: With all the Decos on and flashing blue and plugged into the non-internet connected switch, I fired up the app (I deleted my previous network) and went into initial setup mode.

 

H: I let the Deco app choose the first Deco to pair with.  

 

I: I set it not to be connected to a router, set it to a Dynamic IP, and skipped the last part when it, as expected, was not able to connect to the Internet.

 

J: I got to the “Set up More Decos” or “I am Done” screen and chose to set up more Decos.

 

K: It then found the other three Decos and allowed me to name them.

 

L: It finished the setup, again complained about not being connected to the internet (red light) but that’s Ok.

 

M: You should now be able to get into the main home screen. Go into the Advanced settings and set it to Access Point mode. You will need to wait for all of the Decos to reboot. And get back to the same home screen.

............

 

NOTE: Now we pause the step by step since at this point I tried a number of things to get the Decos to play nice on the network. Every time I failed I had to unplug/replug my ISP router, unplug the slave decos and reboot or unplug/replug the main Deco.

 

My troubleshooting indicates two things:

 

1: My DLink 24 port switch is a problem. The main Deco can use it to connect to the Internet but as soon as any slave Deco connects to it the whole system breaks down and I had to do the procedure I just mentioned in the NOTE.  Tp-Link has mentioned that there is a problem with DLinks.  It persists.

 

2: However, in addition to that, if there is ANY inconsistency at all with the setup when you bring the slaves back, the system will fail and require the NOTE procedure. This includes if a slave has its ethernet connection disconnected at bootup. It seems to go into wireless mode instead and takes everything else down with it.

 

So if you are doing this follow the next steps carefully!

 

......

 

N: You can now unplug all of the Decos.

 

O: Plug the switch you used to test into a port that is connected to the internet/your router or otherwise make the arrangements you need to to get the Decos into their final places while plugged into Ethernet that goes into the same switch you just tested on. Don’t turn them on yet.

 

P: Start by turning on the Main Deco.  Make sure it is green and you can connect to the Internet. It might take a while. You might also need to reset your internet/isp router before it works.

 

Q: Once the Main is working, plug One of the slave decos in. Ensure it is properly connected and green. If it goes red, you will need to reset your ISP/Internet router and reboot the main Deco then troubleshoot the  slave Deco causing a problem.

 

N: Once you do that with all of the slaves, you’ll be done and finally, yes finally, your Ethernet Backhauled Access Point Mode Decos will be working.

........

Done

........

 

it wasn’t all that easy... it really should be easier. The DLink bug in particular should be neutralized in some way or there should be a warning on the app or in the documentation about compatibility with DLink.

 

An indication whether Ethernet or Wireless Backhaul is being used on each Deco would be nice too.

 

Thanks to all the folks in this thread particularly woutermb and others for the hints and tricks that helped.

0
0
#131
Options
Re:Re:Re:Re:Re:How to set up Ethernet Backhaul with your Deco devices (DLink switches issue)
2019-05-16 17:00:44

Thanks to all of you I was able to make my Deco work. My issue was that I have a DLink gigabit switch, 24 ports, and I connected my Deco's to this. After reading this chain of messages I realized that there is an issue when using DLink switches so I connected two of my Deco's to my Apple Airport Extreme (that I was expecting to turn of) and it worked. Right now I am acquiring a gigabit Tp-Link switch, 5 ports, that I will cascade under my Airport Extreme. As you may conclude I will use them as access points instead of routers. Overall I am extremelly satisfied with the performance and usability of these devices. The best feature, that I like most, is that we don't need to create separate names for 2.4GHz and 5GHz. One single name will be handled by these devices.

chrisale wrote

Update: Here is my procedure for getting (I think/assume) Ethernet backhaul to work with the Deco M9 in Access Point mode. This requires a non-DLink switch. It may require all Decos to be communicating directly on the same switch. 

 

A: It appears I have managed to make everything happy but it is definitely finicky, for a few reasons. Hopefully the explanation below helps.

 

B: I started by first resetting the 4 Decos so they were all in blue-flashing light setup mode.

 

C: i also reset my ISPs router/switch so that it was fresh by unplugging/replugging the router. (You need to do this everytime something breaks!)

 

D: I then plugged them all into a simple switch that itself was *disconnected from the internet.

 

E: It was a Netgear brand switch. This probably matters. A D-Link branded switch may not work more on that later.

 

F: As the two ports on the Decos are not marked, I used the port nearest the power to plug into the switch for each Deco.

 

G: With all the Decos on and flashing blue and plugged into the non-internet connected switch, I fired up the app (I deleted my previous network) and went into initial setup mode.

 

H: I let the Deco app choose the first Deco to pair with.  

 

I: I set it not to be connected to a router, set it to a Dynamic IP, and skipped the last part when it, as expected, was not able to connect to the Internet.

 

J: I got to the “Set up More Decos” or “I am Done” screen and chose to set up more Decos.

 

K: It then found the other three Decos and allowed me to name them.

 

L: It finished the setup, again complained about not being connected to the internet (red light) but that’s Ok.

 

M: You should now be able to get into the main home screen. Go into the Advanced settings and set it to Access Point mode. You will need to wait for all of the Decos to reboot. And get back to the same home screen.

............

 

NOTE: Now we pause the step by step since at this point I tried a number of things to get the Decos to play nice on the network. Every time I failed I had to unplug/replug my ISP router, unplug the slave decos and reboot or unplug/replug the main Deco.

 

My troubleshooting indicates two things:

 

1: My DLink 24 port switch is a problem. The main Deco can use it to connect to the Internet but as soon as any slave Deco connects to it the whole system breaks down and I had to do the procedure I just mentioned in the NOTE.  Tp-Link has mentioned that there is a problem with DLinks.  It persists.

 

2: However, in addition to that, if there is ANY inconsistency at all with the setup when you bring the slaves back, the system will fail and require the NOTE procedure. This includes if a slave has its ethernet connection disconnected at bootup. It seems to go into wireless mode instead and takes everything else down with it.

 

So if you are doing this follow the next steps carefully!

 

......

 

N: You can now unplug all of the Decos.

 

O: Plug the switch you used to test into a port that is connected to the internet/your router or otherwise make the arrangements you need to to get the Decos into their final places while plugged into Ethernet that goes into the same switch you just tested on. Don’t turn them on yet.

 

P: Start by turning on the Main Deco.  Make sure it is green and you can connect to the Internet. It might take a while. You might also need to reset your internet/isp router before it works.

 

Q: Once the Main is working, plug One of the slave decos in. Ensure it is properly connected and green. If it goes red, you will need to reset your ISP/Internet router and reboot the main Deco then troubleshoot the  slave Deco causing a problem.

 

N: Once you do that with all of the slaves, you’ll be done and finally, yes finally, your Ethernet Backhauled Access Point Mode Decos will be working.

........

Done

........

 

it wasn’t all that easy... it really should be easier. The DLink bug in particular should be neutralized in some way or there should be a warning on the app or in the documentation about compatibility with DLink.

 

An indication whether Ethernet or Wireless Backhaul is being used on each Deco would be nice too.

 

Thanks to all the folks in this thread particularly woutermb and others for the hints and tricks that helped.

 

0
0
#132
Options
Re:How to set up Ethernet Backhaul with your Deco devices
3 weeks ago

Hi,

 

I have 4 Decos. This tipology could work? Thanks!

 

0
0
#133
Options
Re:Re:How to set up Ethernet Backhaul with your Deco devices
3 weeks ago

Are they all working on access point mode? If so, they still can create a mesh network. 

iGoo wrote

Hi,

 

I have 4 Decos. This tipology could work? Thanks!

 

 

0
0
#134
Options
Re:How to set up Ethernet Backhaul with your Deco devices
3 weeks ago - last edited 3 weeks ago

Very bad.

 

I buy Tplink M4 but it's not work with Ethernet Backhaul

 

Main Deco give me speed 300MB.

 

The slave Deco , give me speed  100MB only   very bad.

 

Tplink Deco M4 not work with Ethernet Backhaul

 

 

0
0
#135
Options
Re:Re:How to set up Ethernet Backhaul with your Deco devices
3 weeks ago

Deco M4 does support Ethernet Backhaul as well.

 

Regarding your problem, may I know how do you connect your two Deco M4 units?

If you have a switch, please make sure the switch together with the Ethernet cable which leads to the second Deco support gigabit connection.

 

In addition, how do you test the speed of the slave Deco? Please try to connect a PC to the other Ethernet port of the unit and make a speed test for a check.

0
0
#136
Options
Re:Re:How to set up Ethernet Backhaul with Deco M5
2 weeks ago

The shame about setting up the M5 triplets as APs is that you lose all the HomeSecure features... Is it possible to use Ethernet backhaul with them in router mode? And is it just the main unit that needs to be configured as router yes? The satellite units do in fact behave as APs of sorts?

Kienzlenator wrote

Spyd wrote

I have the 3 units Deco m5 router pack, and while I had some trouble making it work at first, now that it's working, I'm very happy with it... except that I can't use backhaul.I have the suspicion that it's because I'm using the Deco on AP mode, something I suspect very few people does use, as it wasn't even a feature until a firmware update added it.The situation is the following: I have three decos in a straight line, with one of the ends working as the main one. If I only have the main one connected with an Ethernet cable (to my ISP's router), everything works well, except for the speed that it's not ideal (I have symmetric 600Mpbs Internet connection and a Gigabit NAS, and using the Decos as repeaters and APs slows the speed a lot).The problem arises when I plug an Ethernet cable to the middle Deco; I connect the cable with the Deco turned on and it's light solid green, then the light turns solid red for a second, and then back to solid green, something that it's supposed to tell you that everything is working; except that the wifi does not: the wifi clients show that they're still connected and with good signal strenght, but there's no Internet and the Deco app gets stuck trying to connect to the Decos.If I try to Ping the middle Deco from a Ethernet connected computer while it has the Ethernet cable plugged in, fails about 1 of every 4 pings. If I unplug the Ethernet cable from the Deco, everything works well again (after a minute or so), and when I ping the middle Deco, all pings work ok.I'm using the lastest firmware version (1.2.3 Build 20180819 Rel. 68100) on all three Decos.
I have my three Deco's in AP mode and they work fine in with ethernet backhaul. This is the only system I have found that will support mesh while in AP mode.

 

0
0
#138
Options
Re:Re:How to set up Ethernet Backhaul with Deco M5
2 weeks ago

Don't believe so if it's working right. The key it seems is to make sure the network is first setup as a working WiFi only setup. Then I saw an example of where a poolhouse (nice huh?) had a wired connection for one of the Deco units, since it was clearly too far to bridge wirelessly.

Funky123 wrote

Dear TP,Is is strictly necessary for AP's to be in WiFi range of at least one other AP when they are connected by Ethernet as well?

 

0
0
#139
Options
Re:Re:Re:How to set up Ethernet Backhaul with Deco M5
a week ago

Azlan wrote

The shame about setting up the M5 triplets as APs is that you lose all the HomeSecure features... Is it possible to use Ethernet backhaul with them in router mode? And is it just the main unit that needs to be configured as router yes? The satellite units do in fact behave as APs of sorts?

Kienzlenator wrote

Spyd wrote

I have the 3 units Deco m5 router pack, and while I had some trouble making it work at first, now that it's working, I'm very happy with it... except that I can't use backhaul.I have the suspicion that it's because I'm using the Deco on AP mode, something I suspect very few people does use, as it wasn't even a feature until a firmware update added it.The situation is the following: I have three decos in a straight line, with one of the ends working as the main one. If I only have the main one connected with an Ethernet cable (to my ISP's router), everything works well, except for the speed that it's not ideal (I have symmetric 600Mpbs Internet connection and a Gigabit NAS, and using the Decos as repeaters and APs slows the speed a lot).The problem arises when I plug an Ethernet cable to the middle Deco; I connect the cable with the Deco turned on and it's light solid green, then the light turns solid red for a second, and then back to solid green, something that it's supposed to tell you that everything is working; except that the wifi does not: the wifi clients show that they're still connected and with good signal strenght, but there's no Internet and the Deco app gets stuck trying to connect to the Decos.If I try to Ping the middle Deco from a Ethernet connected computer while it has the Ethernet cable plugged in, fails about 1 of every 4 pings. If I unplug the Ethernet cable from the Deco, everything works well again (after a minute or so), and when I ping the middle Deco, all pings work ok.I'm using the lastest firmware version (1.2.3 Build 20180819 Rel. 68100) on all three Decos.
I have my three Deco's in AP mode and they work fine in with ethernet backhaul. This is the only system I have found that will support mesh while in AP mode.

 

Ethernet Backhaul works in both Router and Access Point mode. 

0
0
#140
Options