Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-24 16:53:47 - last edited 2020-05-29 12:35:08
Model: Tapo C200  
Hardware Version: V1
Firmware Version: 1.0.7

Got 2 of these.  Setup was easy enough.  App pretty good.  RTSP acces works no probs.

 

Then I move to the main reason for buying them, the google home integration.

 

Easy to setup. Control via google home non existent.  Could have lived with that but the availability of the streams via the hub (or any other device for that matter) is garbage.

 

Both cameras giving me the "Sorry, it looks like the stream is currently unavailable for <camera name>."  message more than anything else.  Occasionally they connect, having made no changes, then they dont.  over a period of 4 hours today I the hub managed to display the strema maybe 1 in 50 times.     

 

Been through everyhting mutiple times, config, network (all cameras showing maximum signal) 

 

Massive disappointment and absolutely useless as a Google Home "intgrated" or "smart" security system.

 

 

 

 

  4      
  4      
#1
Options
1 Accepted Solution
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance. -Solution
2020-05-29 12:23:35 - last edited 2020-05-29 12:35:08

@Solla-topee 

I've been using exactly this one 'Hey Google show my <camera name on Chromecast>' but since you asked me to try few others comination I did it as described here https://support.google.com/googlenest/answer/7529598?hl=en 

 

 

To do this:

Say "OK Google" or Hey Google," then..

Start stream

  • "Show [camera name]"
  • "What’s on [camera name]?"
  • "[Camera name] on [Chromecast device name]"
  • "Play [camera name] on [Chromecast device name]"
  • "Show [camera name] on [Chromecast device name]"

Stop stream

"Stop [TV/Chromecast device name]"

 

And yes finally "[Camera name] on [Chromecast device name]" worked ou!

 

Thanks a lot for the suggestion :)

Recommended Solution
  0  
  0  
#9
Options
11 Reply
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-27 02:16:47

@tachikoma1373 

Apologies for all the frustration you've suffered when trying to make this Tapo camera work with your Google Home.

 

The Tapo camera is actually well integrated into the Google Home service and we hope you could give it another try by referring to the below instructions:

How to connect my Tapo device (smart plug, smart camera, smart bulb) to Google Home

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-27 08:53:49 - last edited 2020-05-27 09:02:56

@Solla-topee 

 

Hi,

I'm experiencing a similar situation.

I did the entire process as described into the link above and gave more than a go.., but even if everithing is well configured Google Assistant still reply that is needed a configuration about the device.., but the device is been already configured (as shown in the attachment), so what can be?

 

  0  
  0  
#3
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-28 09:00:14

@paoloc3d 

Please check and ensure both the firmware of your Google device and Google Home app version are up-to-date, then try to add the Tapo camera to it again.

 

If still no help, kindly provide us your Google Home app version and your phone OS version, we will then ask senior engineers to investigate.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#4
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-28 18:53:02

Summary of events....

 

  • Initial install and config in tapo app no problems and stream in the tapo app works.  link google and tplink accounts in google home.  On hub swipe down, select cameras,  both cameras worked and streamed as per expected.

 

minutes later......

 

  • On hub swipe down, select cameras,  both cameras will not stream with same error message "Sorry, it looks like the stream is currently unavailable for <camera name>."

several hours of retries with same result....

  • unlink tplink account from google home
  • check tapo app, all working OK
  • check ISpy (rtsp[ stream no problem) just confirm some other app is able to connect.
  • re-link tp-link account
  • On hub swipe down, select cameras,  both cameras will not stream with same error message "Sorry, it looks like the stream is currently unavailable for <camera name>."
  • check tapo app - working fine
  • check ispy - working fine
  • accounts in google home.  On hub swipe down, select camera 1 ,  camera worked and streamed as per expected.
  • accounts in google home.  On hub swipe down, select camera 2 ,  camera will not stream with same error message "Sorry, it looks like the stream is currently unavailable for <camera name>."
  • accounts in google home.  On hub swipe down, select camera 1 ,  camera will not stream with same error message "Sorry, it looks like the stream is currently unavailable for <camera name>."  (Note this worked moments before)

 

another few hours of the same thing...

 

  • everything works in the tapo app, everything works in Ispy, nothing works in Google home - same error all the time "Sorry, it looks like the stream is currently unavailable for <camera name>."

 

next day several hours of the same routine then suddenly all starts working and has done since.

 

 

Note:

All devices were updated to latest firmware prior to original configuration and switched to auto update where possible.

All devices on same network AC across 2.4 (cameras) and 5 Ghz (all other home devices) bands.

 

ZERO changes have been made to any network configurations during all the testing.  All other Google home devices (nest mini v2 hub x2 and TPlink power socket worked without issue throughout).

 

The TP-link rep i first chatted with kept trying to come back and say that if the app worked then there was nothing wrong.  Given the product is sold as integrating with google if that aint working then its still your responsibility to support that element - maybe tell your support team that!

 

He/she also told me that iSpy doesnt work with C200 cameras.  and continued to do so even after i told him that i was watching it as I typed AND the reason I used it to test was because the TP-link FAQ said it worked!

 

 

  0  
  0  
#5
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-29 08:14:29 - last edited 2020-05-29 08:27:52

Hi @Solla-topee 

thank you for the prompt replay

 

TP-Link device

Model: Tapo C200

Hardware Version: V1

Firmware Version: 1.0.7

 

Smartphone OS

Model: Samsung Galaxy S10 Plus

Android version: 10

 

Google device

Google Chromecast

Firmware Version: 1.42.172094

Country code: IT

 

Google Home App version 2.22.1.11

 

I've unlinked Tapo app from Google Home, linked it back againg. New attempt to stream C200 on the Chromecast by Google Assistant but nothing, same answer as before: "The device has not been configured yet. You can do it by Google Home app."

  0  
  0  
#6
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-29 12:00:19

@tachikoma1373 

It's glad to hear that the issue is finally resolved and hope you could enjoy our camera.

 

For the support agent, we will check and coach him/her and hope you could better customer support experience next time.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#7
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-29 12:05:18

@paoloc3d 

May I know what voice command you've used to show the camera? Please try with different voice commands like 'Hey Google show my <camera name on Chromecast>', we will also verify again with Google team and investigate further.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#8
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance. -Solution
2020-05-29 12:23:35 - last edited 2020-05-29 12:35:08

@Solla-topee 

I've been using exactly this one 'Hey Google show my <camera name on Chromecast>' but since you asked me to try few others comination I did it as described here https://support.google.com/googlenest/answer/7529598?hl=en 

 

 

To do this:

Say "OK Google" or Hey Google," then..

Start stream

  • "Show [camera name]"
  • "What’s on [camera name]?"
  • "[Camera name] on [Chromecast device name]"
  • "Play [camera name] on [Chromecast device name]"
  • "Show [camera name] on [Chromecast device name]"

Stop stream

"Stop [TV/Chromecast device name]"

 

And yes finally "[Camera name] on [Chromecast device name]" worked ou!

 

Thanks a lot for the suggestion :)

Recommended Solution
  0  
  0  
#9
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2020-05-29 12:34:03

@paoloc3d 

Thanks for your update and it's glad to hear that the issue is resolved, enjoy it.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  1  
  1  
#10
Options
Re:Tapo c200 impressions - absolute garbage Google Home integration and even worse performance.
2021-09-08 17:23:01

@tachikoma1373 

 

This doesn't solve the problem the camera feed closes after a few minutes. I want the feed to stay there all the time and, also, I'd like to stream all my cameras at once on my Google Nest Hub 2 continuously whenever I am not doing anything else. If I ask Google to Stream the Camera(s) I want the stream to stay there running. I don't care about your bandwidth, you should have implemented this integration better if you didn't want to burn money on bandwidth and make our feed lag even when everything is indeed in the same network. You should have integrated in a manner it sends the feed via local network.

 

I'd appreciate if anybody has a solution to that problem because I got your camera specifically because I have Google Displays I want to use to stream the camera feed to. 😟

  1  
  1  
#11
Options