C100 camera: date and time resets to year 2015

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

C100 camera: date and time resets to year 2015

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
C100 camera: date and time resets to year 2015
C100 camera: date and time resets to year 2015
2020-10-05 19:00:59 - last edited 2020-10-09 21:27:43
Model: Tapo C100  
Hardware Version:
Firmware Version:

I have a problem with my Tapo C100 camera: several times a day, it resets its on-screen display of date and time to "2015-09-07 07:30:07" and then starts counting up from that time.

 

I can make it display the correct date and time by using the app to select a different time zone and then select the original time zone again.  But a few hours later, it reverts again to the year 2015 and always the same date/time.

 

This is clearly an NTP-related issue (or a bug in the firmware).  To try and narrow down the cause, I've captured at my firewall all outbound packets from the device to udp/123.  I've found that changing its time zone via the app provokes a substantial burst of NTP activity.  Over the 58 minutes following a change of time zone, the C100 issues 467 NTP requests to 10 different time servers, even though the correct time is displayed almost immediately. For each time server, it issues between 41 and 76 requests.  After the 58-minute burst of NTP activity, it goes quiet for a few hours.

 

I haven't yet isolated the "revert to 2015" event to a particular NTP request but I could do so given enough effort.  Before I waste any more time on this, I'd appreciate comments, ideas and suggestions.  I feel inclined to firewall out all but one time server and see if that has any effect.  I'm more inclined to the view that this is a bug in the firmware.

 

Has anyone else observed this?

 

 

 

  1      
  1      
#1
Options
5 Reply
Re:C100 camera: date and time resets to year 2015
2020-10-06 15:02:35 - last edited 2020-10-09 21:27:43

Edit: DESPITE THIS POST BEING MARKED AS A "SOLUTION", IT ISN'T.  Most people won't be able to firewall the device and even if they could, doing so isn't a solution.

 

I've investigated this further.  The ten time servers interrogated by the C100 in its 58-minute burst of NTP activity following a time zone change are:

 

103.214.220.220   mika.470n.act.tsgnl.co (Australia)
128.138.140.44     utcnist.colorado.edu
129.6.15.28           time-a-g.nist.gov
129.6.15.29           time-b-g.nist.gov
131.107.13.100     Microsoft (no RDNS)
132.163.97.3         time-c-wwv.nist.gov
133.100.9.2           Fukuoka University, Japan (No RDNS)
162.159.200.1       time.cloudflare.com
192.36.144.22       sth1.ntp.se
51.105.208.173     Microsoft (no RDNS)

 

I've checked each of these time servers using "ntpdate -q" and they're all responding with the correct date and time except for the Microsoft server at 131.107.13.100, which isn't running an active time server and doesn't respond.

 

Could there be a firmware bug that interprets a lack of response from one of these servers as a reason to set a default date and time in the year 2015?

 

I've "fixed" the problem by configuring my firewall to block all NTP traffic from the C100 except that addressed to time.cloudflare.com.  This change has worked: the C100 camera now displays the correct date and time and no longer arbitrarily sets it every few hours to the year 2015.

 

Would anyone from TP-Link care to comment?  This really needs to be fixed.

 

  1  
  1  
#2
Options
Re:C100 camera: date and time resets to year 2015
2020-10-09 21:24:12

Unfortunately, the firewall change described above hasn't fixed the issue.  Although the camera displayed the correct date and time for longer after this change, it's now reverted back to a date and time in the year 2015.

 

Does TP-Link monitor this forum at all?  This is clearly a firmware bug and it would be good to have some response from the manufacturer.

  0  
  0  
#3
Options
Re:C100 camera: date and time resets to year 2015
2020-10-12 19:11:09

Does anyone know how to report a bug to TP-Link?

  0  
  0  
#4
Options
Re:C100 camera: date and time resets to year 2015
2021-07-29 13:56:23

@ashdown 

 

Same issue here angry

Any fix?

  0  
  0  
#5
Options
Re:C100 camera: date and time resets to year 2015
2021-07-29 18:05:47

@WeatherWitch 

 

I do wonder why TP-Link bother to run a community forum.  Either they don't monitor it or they can't be bothered to fix bugs.  Either way, it's pretty poor publicity for the TP-Link brand and discourages any further purchase,

 

This is clearly a firmware bug, it's easily reproduced and would be simple to fix.  Don't TP-Link care?

  0  
  0  
#6
Options

Information

Helpful: 1

Views: 1107

Replies: 5

Related Articles