Tapo C200 "Failed to receive IP Address" out of nowhere

Tapo C200 "Failed to receive IP Address" out of nowhere

Tapo C200 "Failed to receive IP Address" out of nowhere
Tapo C200 "Failed to receive IP Address" out of nowhere
2021-07-21 12:02:02 - last edited 2022-07-05 06:02:17
Model: Tapo C200  
Hardware Version: V1
Firmware Version: 1.1.11

A.The model number of the camera and how many cameras do you have in total and the affected camera.

  • Tapo C200
  • 2 Cameras for now

B.The hardware and firmware version of the camera.

  • Hardware v1.0 firmware 1.1.11 and
  • Hardware v2.0 firware 1.1.9

C.The troubleshooting methods you have tried and the results.

  • Resetting more than 10+ times already
  • Unplug and replug
  • Waiting for 10 hours
  • Switching location
  • Setting it up right beside the router
  • Monitoring associated devices and seeing the IP Address appear
  • Changing different parameters of router
  • Repeating all of the above for 2 days now

D.The model number of the main router.

  • ZTE F670L

E.The purchase date of the camera.

  • Hardware v1.0: August 2020
  • Hardware v2.0: July 2021

 

My main issue is that the hardware v1.0 went offline. The green light was blinking and I left it for 10 hours after unplugging it again and again. After that, I decided to reset it, but it said "Failed to receive IP Address". The 2nd one (hardware v2.0) was working fine, so I decided to place that in the malfunctioning camera's position. UNEXPECTEDLY, this one suddenly couldn't connect to the WiFi either. It was working before I unplugged it, but suddenly stopped working after. Now I've reset the hardware v1.0 more than 10 times and the hardware v2.0 about 5 times now. Each time using different parameters. Take note that everything was working before 12am, July 21, 2021 GMT+8. I just saw that the hardware v1.0 was offline at around 1:00am. 

 

Is there something wrong with the Tapo server or firmware? I can't check the firmware update without connecting. I can clearly see that the camera is able to obtain an IP Address, but disconnects a few seconds after receiving an IP Address. I've honestly not seen this issue before I updated both cameras. The hardware v1.0 was working perfectly fine 24/7 for months on end until recently. I regret updating or even changing anything because it's causing so much issues to have both my cameras offline.

  0      
  0      
#1
Options
2 Accepted Solutions
Re:Tapo C200 "Failed to receive IP Address" out of nowhere-Solution
2021-07-22 02:41:00 - last edited 2023-07-20 12:44:12
Update on July 20, 2023.

Hello everyone, 
If you experience the ‘Failed to receive IP address’ error when setting up Tapo cameras, here are some suggestions that you can give a try: 

1. Disable the modem/router Firewall settings or MAC Filtering feature that may block the camera. And please pay attention to rebooting the modem/router to make the changes take effect.
2. Check if there are any advanced settings on the router like Access Control/Parental Control settings may affect the camera. If yes, turn them off for a test.
3. Change the router's DNS to 8.8.8.8/ 8.8.4.4
4. Reboot the camera and modem.
5. Make sure the camera is connected to the router directly, not through other AP or Range extenders
6. Connect the smart camera to a phone's hotspot Wi-Fi network for a try. If you can set up the camera successfully, update the firmware for the camera and then reinstall it with router Wi-Fi.

If the above suggestions are not working, it's encouraged to describe your problem and troubleshooting steps in detail, and then Start a New Thread to get further assistance with the following information.
  • Model of your router  
  • Please check the router network client list / DHCP client list and see if the Tapo camera has got an IP address from the router.
  • The Led status on camera, such as solid/flashing green/red/amber, etc.
  • A photo of the error message on the Tapo app
  • Model and OS of your phone
  • Tapo APP version
    

 

Best Regards

More Articles:
What should I do if I fail to configure Tapo Camera?
What should I do if my Tapo smart camera keeps losing connection or going Offline?

Recommended Solution
  0  
  0  
#2
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere-Solution
2022-03-06 07:32:53 - last edited 2022-07-05 06:02:17

  @Winwin3642 I had the same problem, and my solution is the following:

It has to do with the encryption setting of your router. Since the camera does not work well with AES encryption in my experience. I have changed the method of encryption to "Auto" so it actually uses the TKIP. After this change it works like a charm!!

Recommended Solution
  28  
  28  
#7
Options
23 Reply
Re:Tapo C200 "Failed to receive IP Address" out of nowhere-Solution
2021-07-22 02:41:00 - last edited 2023-07-20 12:44:12
Update on July 20, 2023.

Hello everyone, 
If you experience the ‘Failed to receive IP address’ error when setting up Tapo cameras, here are some suggestions that you can give a try: 

1. Disable the modem/router Firewall settings or MAC Filtering feature that may block the camera. And please pay attention to rebooting the modem/router to make the changes take effect.
2. Check if there are any advanced settings on the router like Access Control/Parental Control settings may affect the camera. If yes, turn them off for a test.
3. Change the router's DNS to 8.8.8.8/ 8.8.4.4
4. Reboot the camera and modem.
5. Make sure the camera is connected to the router directly, not through other AP or Range extenders
6. Connect the smart camera to a phone's hotspot Wi-Fi network for a try. If you can set up the camera successfully, update the firmware for the camera and then reinstall it with router Wi-Fi.

If the above suggestions are not working, it's encouraged to describe your problem and troubleshooting steps in detail, and then Start a New Thread to get further assistance with the following information.
  • Model of your router  
  • Please check the router network client list / DHCP client list and see if the Tapo camera has got an IP address from the router.
  • The Led status on camera, such as solid/flashing green/red/amber, etc.
  • A photo of the error message on the Tapo app
  • Model and OS of your phone
  • Tapo APP version
    

 

Best Regards

More Articles:
What should I do if I fail to configure Tapo Camera?
What should I do if my Tapo smart camera keeps losing connection or going Offline?

Recommended Solution
  0  
  0  
#2
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2021-07-22 05:21:42

@Solla-topee 

1. Yes, I've tried turning off all firewalls and any other features

2. The router is basic and has no such features

3. The router's DNS cannot also be changed. The only available modification is Port Forwarding

4. Done multiple times

5. We don't have other AP or Range extenders. I have tried different SSIDs since the router provides up to 4 SSIDs. This worked for 1 day, but immediately stopped after for both. I was able to setup 2 other cameras (in storage) using both SSIDs about 2-3 days ago, but I haven't checked up on those.

 

I can't send images in messages, so I've attached the log of my camera being registered with an IP Address even if it announces "Failed to receive IP Address"

 

Figure 1. Associated Devices log of my router showing my Tapo C200 Camera (I sent the full MAC Address via message) to the router with an IP Address, despite saying it failed to receive one.

Figure 2. Error message received on my phone after inputting SSID and password.

  10  
  10  
#3
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2021-07-22 11:33:56

@Winwin3642 Thanks so much for sharing all the detailed info, this issue you are experiencing sounds unusual. To address the issue and try to fix it, we would like to have a specialist look into this further via email. Please check your mailbox later, and let us know if the issue is resolved. Thank you!

  0  
  0  
#4
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2021-09-27 22:46:28

@Winwin3642 did you end up solving this?

 

I just bought a C200 camera and I'm having the same problem.

 

After trying to set an IP reservation on my router (UniFi Dream Machine), and restarting the camera, it no longer connects. I reset it and now it constantly says "Failed to receive IP address".

  0  
  0  
#5
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2021-09-27 23:49:00 - last edited 2023-07-20 12:44:09

@ttarik Yeah. I replaced my router. I don't exactly know why my Tapo C200 couldn't connect properly, but it appeared as one of the connected devices for 5 seconds and would disappear and say "Failed to receive IP Address". It was also kind of time to upgrade to a Mesh Wifi, so I got the TP-Link Deco E4 (3-pack) and now it works fine. 

  0  
  0  
#6
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere-Solution
2022-03-06 07:32:53 - last edited 2022-07-05 06:02:17

  @Winwin3642 I had the same problem, and my solution is the following:

It has to do with the encryption setting of your router. Since the camera does not work well with AES encryption in my experience. I have changed the method of encryption to "Auto" so it actually uses the TKIP. After this change it works like a charm!!

Recommended Solution
  28  
  28  
#7
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2022-03-07 02:12:32

Hello   @FrisianPieter 

Thank you for sharing your experience and let us know your solution here in the community. May I have a chance to know the model of router, is it on WPA2-AES or WPA3 before? 

  4  
  4  
#8
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2022-07-01 16:51:13

  @Solla-topee 

 

I am having the same issue.

 

I cant even setup the camera at all. "failed to receive IP address". 

Router is a D-Link DIR-1760, camera is the C200.

 

Tried via the ios app and android app. nada.

this is from a brand new camera, on first setup.

Someone please help

  12  
  12  
#9
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2022-07-05 06:15:03

  @Pete9000 thank you for the feedback, you could also try some tips on #2 of this thread

If possible, you could check if modem & router has any firewall settings and adjust firewall settings, change router DNS settings to 8.8.8.8. 

  0  
  0  
#10
Options
Re:Tapo C200 "Failed to receive IP Address" out of nowhere
2022-07-05 06:40:12 - last edited 2022-07-05 06:41:38

  @Pete9000 You can try using your mobile hotspot to set it up. If this works, your router might be the cause. It could be the encryption isn't compatible with the C200, so you might have to change the encryption or possibly replace the router/camera. I'm not too sure what happened to mine, but I chose to change routers since I also wanted a Mesh Wifi.

  2  
  2  
#11
Options

Information

Helpful: 0

Views: 14156

Replies: 23

Related Articles