Temporary problem every time I turn the light on

Temporary problem every time I turn the light on
Temporary problem every time I turn the light on
2021-12-28 12:00:55
Model: KL130
Hardware Version: V1
Firmware Version: 1.0.6

Hiya,

 

First time posting here.

 

I've the KL135, it didn't let me select it on the models list. Closest thing was the KL130.

 

Firstly, whenever the wall switch is on and the bulb is turned off from the Kasa or Alexa apps, or via voice command through my Echo, there's a very soft glow. I'm not sure if this is by design or not, so I'm not counting that as a problem per se. It also doesn't bother me, it's kinda nice even, but the light only goes completely off when I switch it off from the wall switch, which I never do, so it always has at least that minimal glow. I've checked and it's less than 1% brightness on any color or white temperature. It's mostly visible at night when it's dark. During the day you barely notice it.

 

Now, besides that, every time I turn it on, either from my Echo, the Alexa app on my phone, or the Kasa app on my phone, the following things are wrong for the first couple of minutes:

 

On the Kasa app:

  • The light turns on but it doesn't keep the previous setting. It turns on in the white temperature that's in the middle on the Alexa app (I haven't checked what the actual temperature is).
  • The brightness is at 100% and the brightness toggle doesn't change brightness but instead changes the temperature for the white. The lower the brightness you set, the warmer the white. The screen for you to change the temperature works as intended, it changes the temperature.
  • If you go to the color screen to choose a specific color after you first turned the bulb on on the app, you're able to set whatever color you want but you're only able to control brightness from maybe 50% to 100% (I'm guessing it's 50%, maybe it's more, but it doesn't go to the minimum brightness for sure).
  • If you select a color from the edge of the color palette, you have full brightness control as it should be, and you're able to select any random color you want on the edge of the color palette after that and still control brightness fully. However, as soon as you select any other color that's not on the edge, the light defaults to white with a very slight tint of the color you're selecting, regardless of where on the palette it is, as if you were selecting something almost close to the center. Changing anything on the brightness screen generates a weird mix of the same color but with a warmer tone (since the brightness toggle only controls temperature unless you're on one of the colors that are on the edge).

 

On the Alexa app and via voice command through my Echo:

  • If I remember correctly, nothing responds, basically. You can set anything you want, but it just doesn't respond.

 

After a few minutes, maybe 2 or 3, it catches up to everything you tried to do while it wasn't responding properly and does it and then everything works as it should from then on. Once you turn it off and turn it back on, it sometimes works correctly from the start and sometimes it takes a few minutes again.

 

It's worth noting that every time I say I turn it on and off I mean from the Kasa app, the Alexa app, or via voice command from my Echo. I've mostly left the wall switch on except for a couple times Alexa and the Kasa app showed it wasn't responding even though it was getting power (I could tell because of the subtle glow I'd mentioned above that's always showing when the switch is on but the bulb has been turned off through the apps or the Echo), so I turned it off from the switch, on again, and then we were back to the normal stuff (the problems above, not actual normal with it working properly).

 

Is any of this normal? Cuz if it is, great, it's normal, but if it's not, I'd really wanna start looking for a solution.

0
0
#1
Options
6 Reply
Re:Temporary problem every time I turn the light on
2021-12-30 09:36:16 - last edited 2021-12-30 09:39:54

Hello @nahuelma97 

 

May I know did  you purchase the KL135 in the US and use it in the US?

(US) version bulbs need to work under 100-120V as Q9  in FAQ here. 

 

The bulb behavior you describe does not sound usual,  1) Alexa should be turn off Bulb completely, and 2) Kasa APP brightness or color adjustment does not sound correct. 

I would like to create a support email to investigate further, can you share some video for 1) 2) showing the issues via email, thank you. 

0
0
#2
Options
Re:Temporary problem every time I turn the light on
2022-03-30 13:12:26

  @nahuelma97 was your issue ever solved?

I recently bought TWO these bulbs from Amazon US and replaced my KL130 with them. I have used the LK130s for quite a long time. The only reason I got these KL135s is that I read from Amazon reviews that they are brighter (1000 lumens instead of the 800 lumens for the KL130) and that these ones come with power monitoring.

First, I must admit that I don't live in the US - never been there :-) I use these bulbs in KE where we are 220V-240V. The KL130s have worked for me for years so I wasn't worried about these KL135s.

I haven't played much with them since I installed them only yesterday (20220329) but my Alexa is able to control them (ON/OFF). The color changes by Alexa are instant and even when I ask Alexa to turn on the bulbs, they come back with the previous color that had been set.

The only thing I realized is that glow you mentioned - that these lights did not seem to completely go OFF completely when I ask Alexa to turn them off. Then one of them finally agreed to completely while one still maintains that glow.

I would say that I also don't mind the glow, but it would have been better if it wasn't there.

I also have 2 Tapo (P100) sockets, 2 Kasa (KP115) sockets (with energy monitoring), LB230 (also bought from the US and which works great!), KL430/430E and recently a KL420L5. Basically my lighting has been a TP-Link ecosystem (with a few Govee and 1 Wyze Lighting).

 

I know my response is most likely to be ignored by the TP-Link team because I am using these bulbs in a region where they aren't meant to be used.

If you ever find a solution to the glow kindly let me know.

 

2
2
#3
Options
Re:Temporary problem every time I turn the light on
2022-03-31 16:19:21 - last edited 2022-03-31 16:22:27

Hello   @odhiambo 

Thank you for sharing experince here.  Good to know that your old KL130 has worked for a long time, while (US) version Kasa  bulbs need to work under 100-120v, higher voltage may cause some damage on the bulbs. Even in the lab we use a transformer when test the US vesion smart bulb. 

 

0
0
#4
Options
Re:Temporary problem every time I turn the light on
2022-03-31 16:44:51

@Solla-topee thanks for your reply. My KL130 (I have many of them, plus my friend also bought the same) and they are working well. We must be lucky!

I will consider keeping a few of the UK versions (KL130B) since they are rated 240V.

Are there plans for a KL135B though?

0
0
#5
Options
Re:Temporary problem every time I turn the light on
2022-03-31 18:29:15

hello  @odhiambo  thank you for your fond of kasa device. So far I only see KL135(US) version avalaible while checking some internal resorces. As product plan could change before an official release, for new product we usually recommend keeping an eye on our websitelaugh

0
0
#6
Options
Re:Temporary problem every time I turn the light on
2022-05-30 05:23:55

Had the same issue. I don't know which app it was, but I opened all my iOS apps that control the Hue bulbs, force quit them all, and now the bulb I was having issues with functions as expected.

I did try and delete if from the Hue app and set it up again without success. Power cycling the bulb didn't have any affect either.

0
0
#7
Options