RE450 wil not detect 5G SID

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

RE450 wil not detect 5G SID

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
RE450 wil not detect 5G SID
RE450 wil not detect 5G SID
2022-08-01 04:22:43
Model: RE450  
Hardware Version: V4
Firmware Version: 1.0.4 Build 210531 Rel.34858n (6585)

This access point refuses to detect 5G SIDs 

I am extremely disappointed with tp-link right now. Especially after the support woman hung uo the phone because the problem was obviously to complicated for her, 

I have. 

Upgraded firmware. 
Tried all channels in the core router. 
Assigned it different IP ranges
Tried configuring it with both manual and static IPs
Tried a different core router
Tried distances.

I use this unit extender to speak to my core router and plug my laptop directly into it. (Logging into the GUI shows 2.4Ghz SID only) 

It wil only detect the 2.4GHZ SID 

I have found many people in this forum report the same issues. I have not seen TPLINK provide an actual resolution to date. 

May I also ask. What's the with advertising on the box? It actually states 2.4GHZ up to 450mbps. How can that be? That's impossible. 2.4GHZ is max 54Mpbs 

So I have a 300mpbs internet connection here. I can only connect/detect my home core routers 2.4Ghz SID at a line rate of 54Mpbs. Which is the MAX for 2.4Ghz. So beats me why TP/LINK claim up 450Mbps on 2.4Ghz has stated on the box. I am amazed with this claim 

1. My past reports and disappointment here in this forum was deleted 
2. My over the phone support call got hung up on when the woman simply could not understand the issue. 

On the box - "Works with any router" ( No it dose not) Even tried two) 

It's of my personal opinion this product should be recalled.The advertising of 2.4GHZ up to 450mpbs should also be removed. 

Tried support forums (No resolution for *ANY* customer complaining about the issues with this unit)
Tried over the phone support (Got hung up on when it go to hard for her and had to explain the issues 3 times)
Called a second time and third time to get back to them (Now no answer leave a message) 
I would like the direct number for management in Australia. Or speak to corporate 


1 Reply
Re:RE450 wil not detect 5G SID
2022-08-02 06:40:07 - last edited 2022-08-02 06:52:17

 Hello  @Not-routed 

It's good to know now RE has connected to the 5Ghz router finally in your recent post

  • For RE not able to see the 5Ghz Wi-Fi signal, we made a troubleshooting guide, if anyone experiences the same problem, please try some tips here first: 

[Troubleshooting] TP-Link Range Extender is not detecting the 5GHz Signal of the Main Router

Most of the time range extender does not see the router's 5Ghz  due to the router's 5Ghz channel as explained in the above guide, in few cases it could be a faulty extender or something else, and there is no existing known issue for this model 5Ghz. 

Sorry to hear about your experience with the support is less than satisfactory, we will share your feedback here with our team to keep improving our service. 

​​​​​​​If the problem persists,  kindly help provide the requested information in the above troubleshooting guide like the photo of the router's 5Ghz Wi-Fi setting, etc, and we'd take a further look at it. 




Smart Action 2.0 Explore and meet the next level home automation.


Helpful: 0

Views: 208

Replies: 2