AC1200 router getting "Invalid RSA public key" error

AC1200 router getting "Invalid RSA public key" error
AC1200 router getting "Invalid RSA public key" error
2018-09-01 19:10:00 - last edited 2019-11-06 10:17:53
Model :

Hardware Version :

Firmware Version :

ISP :

Hello.

I went to make an adjustment to my AC1200 router yesterday, and I'm getting getting an "Invalid RSA public key" error when I try to login to the router. I attached a screenshot. Never had this problem before. No recent FW changes or anything. Tried different browsers and PC's, on both Win 7 and 10. Tried manually rebooting the router too. Cannot seem to find anything online. Don't want to do a reset as I have some custom configs setup.

Any thoughts?
File:
RSA error.JPGDownload
0
0
#1
Options
1 Accepted Solution
Re:AC1200 router getting "Invalid RSA public key" error-Solution
2019-11-06 10:17:25 - last edited 2019-11-06 10:17:53

Hi all,

 

You can refer to case 5 of https://www.tp-link.com/support/faq/2657/

 

Best regards. 

Recommended Solution
0
0
#6
Options
6 Reply
Re:AC1200 router getting "Invalid RSA public key" error
2018-09-02 19:02:04
Anyone?
0
0
#2
Options
Re:AC1200 router getting "Invalid RSA public key" error
2018-09-17 01:23:22
Have not seen this before. By chance do you have a backup of the router prior to the changes? What changes did you make?
Are you connecting via WIFI or cable?
Try deleting the network from your PC, restart the PC and re connect.
You may have to bite the bullet and do a reset on the router.
Let us know what works.
0
0
#4
Options
Re:AC1200 router getting "Invalid RSA public key" error-Solution
2019-11-06 10:17:25 - last edited 2019-11-06 10:17:53

Hi all,

 

You can refer to case 5 of https://www.tp-link.com/support/faq/2657/

 

Best regards. 

Recommended Solution
0
0
#6
Options
Re:AC1200 router getting "Invalid RSA public key" error
2020-09-23 13:46:06

@BigVic hello I have this code on invalid RSA pablic key please help me

0
0
#7
Options
Re:AC1200 router getting "Invalid RSA public key" error
2020-10-07 18:46:37

I get the same on AC-2600.

Have tried from multiple browsers and three other computers/phones.

 

This has nothing to do with the buffer memory as another KB article suggests.

Please advise.

 

1
1
#9
Options
Re:AC1200 router getting "Invalid RSA public key" error
2021-02-05 20:47:41

@Kevin_Z. I have the same problem, and that solution does not work. Clearing the cache, using different browsers, etc.  do not help at all and the RSA error remains. 

0
0
#10
Options