Archer C9 - guest wifi

Archer C9 - guest wifi
Archer C9 - guest wifi
2018-09-11 09:50:21
Model :

Hardware Version :

Firmware Version :

ISP :

I have an Archer C9 (dual-band AC wireless router)
Hardware version: Archer C9 v3.0
Firmware Version: 1.3.1 Build 20171215

I used Advanced -> Guest Network to set up wireless networks for guests (both a guest 2.4ghz and a guest 5.0ghz). I assigned the same password to both.

I set up the same two guest networks, with the same SSID, on my other Archer C9, which is set up as a Wireless Access Point (WAP) only.

Guests can log in to either network. However when they do log in (from iphones) they see the words "no internet connection" next to the network name.

I looked through the support information in the advanced setup page of the router, but found no information

The point of having a guest network, I think, is to allow guests to use the internet without giving them access to my local network shares; so I have "Allow guests to access my local network" unchecked.
0
0
#1
Options
2 Replies
Re:Archer C9 - guest wifi
2018-09-16 19:57:59
On the iPhones, have them "forget the network" and then connect to the network reentering the passwords.
Be sure all of the settings on the guest network are the same including the security settings. Be sure you use WIFI security. I have had issues connecting to unsecure networks with my iPad.
I also like to re-boot the router after making router changes. Seems to help with some changes.
If that does not work, try disabling one of the guest network to see if that works. Be sure the one left enabled is on the band the iPhone can use.
Next try a different SSID on one of the networks. Most phones and tablets will allow multiple networks to be setup and switch between them without issue.
Let us know what works for you.
0
0
#2
Options
Re:Re:Archer C9 - guest wifi
2018-12-26 16:50:48 - last edited 2018-12-26 18:20:57

I have determined more information about what is causing this problem, but I still need a solution.

 

Because the building is too large to have wifi service from only one router, we operate two routers, called "Locked1" and "Locked2". Both are tp-link Archer C9.

 

Locked1 specifications:

  • Archer C9 v.3.0 with firmware 1.3.1 Build 20171215 rel.35219
  • This is the main router for the building. It does DHCP and wireless access.
  • It is connected to the cablemodem using its WAN port.
  • This unit broadcasts four SSIDs, called:
    • Locked1_24ghz
    • Locked1_5ghz
    • Guest1_24ghz
    • Guest1_5ghz
  • All four SSIDs are working correctly and providing internet access.

 

Locked2 specifications:

  • Archer C9 v.4.0 with firmware 1.0.1 Build 20171219
  • This is the secondary unit. It is located at the other end of the building in order to provide wifi coverage to that end of the building.
  • This router serves as a WAP only. DHCP is turned off.
  • Locked2 connects to Locked1 using a cat-5 cable. This cable goes from one of the four ethernet ports on Locked1 to one of the four ethernet ports on Locked2.
  • This unit broadcasts four SSIDs, called:
    • Locked2_24ghz   [working]
    • Locked2_5ghz     [working]
    • Guest2_24ghz     [no internet]
    • Guest2_5ghz       [no internet]
  • The two Locked2 SSIDs are working correctly and providing internet access.
  • The two Guest2 SSIDs are broadcasting, and devices can connect to them. However the devices that connect to Guest2_24ghz and Guets2_5ghz have no internet access.

 

So guests who connect to either Guest SSID of Locked1 have internet access, but guests who connect to either of the Guest SSIDs on Locked2 have no internet access at all. This is creating a big problem! 

 

I need help determining what changes I need to make to the configuration of Locked2 in order to provide internet access to the guests at that end of the building.

 

Here is a screenshot of my current settings for Locked2. This is the advanced configuration -> Network -> Internet.

Note the "WAN Port is unplugged" message. It is my understanding that in order for Locked2 to function as a WAP only, it must be connected to Locked1 using one of the LAN ports, not the WAN port.

 

Here is a screenshot of Locked2 Advanced mode -> Status. Note the red X by "Internet."

 

0
0
#3
Options