[Solution] Main Deco frequently disconnects from the Internet under Spectrum service

[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-08-11 00:55:03 - last edited 2021-11-30 01:34:45

This Article Applies to:
All models of Deco

 

Issue Description/Phenomenon:
It's been reported that the Deco may lose Internet connection frequently under Spectrum network.  The main Deco may turn red, rebooting the Deco or unplugging/plugging the Ethernet cable from the modem could restore the connection. 

 

However, if the connection doesn't recover by power cycling the Deco,  unless power cycling the Spectrum modem, you're strongly suggested to contact Spectrum to troubleshoot first. On some occasions, the "Online" LED on the Spectrum modem always remains illuminated, while you're actually get disconnected from their network.

 

It's also suggested to verify the IP address on the Deco network (Open the Deco App > More > Advanced > IPv4) when the issue happens. If the IPv4 address is all 0.0.0.0, the disconnection might be also caused by the line or modem,  try to contact Spectrum for further assistance.

 

If Spectrum confirms there is nothing wrong on their end or with the modem, please continue to read on.

 

Available Solutions:

If the internet access could be easily restored by power cycling the Deco or Spectrum has confirmed the internet connection is all good from their end, please install the following beta firmware accordingly on the Deco and check whether the issue could be solved.

 

Download link for the beta firmware:

Deco M4 1.5.2 build 20211124

 

Deco S4 1.5.0 build 20211119


Deco M5 1.5.3 build 20210726
 

Deco M9 Plus V2 1.5.0 build 20210623

 

Deco X20 V1 1.5.0 build 20210803
 

Deco X20 V1.2 1.5.0 build 20210803

 

Deco X60 V1 1.5.0 build 20210803
 
Deco X60 V2 1.5.1 build 20210701

Deco W3600 V1 1.5.0 build 20210803

 

Note: Please check the device label to verify the hardware version of your device first, and choose the correct file to download and install.
 

For the unstable connection with other ISPs, the beta firmware is also worth a try.  And If in any cases the issue is not fixed, please email support.forum@tp-link.com with the subject [Forum ID 273078] Main Deco frequently disconnects from the Internet under Spectrum service with the debug logs.
 

Procedures to get the debug logs:
1. When the issue occurs again, connect a PC to one of the Deco nodes.
2. Open the web browser and go to http://tplinkdeco.net.
3. Go to Advanced > System > System log > Select log type as Debug and save it.

Note:
1. Please DO NOT reboot the Deco before you save the log.
2. Please save the system log within 30 minutes after the main Deco turns red.

0
0
#1
Options
11 Reply
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-09-16 14:05:58

@TP-Link While Spectrum is not my ISP, WOW! (Wide Open West) is my ISP and I was having almost identical issues. I found this thread after losing connectivity seemingly from my ISP, about 30 times per day, albeit briefly. I have installed this firmware and rebooted everything. I have only had one drop for 12 seconds in the last 4 hours. I didn't even realize it, so I was unable to grab the debug log, but if it drops again, I will grab it and post it. Thanks for working on this, I really do love my M9 Plus mesh!

2
2
#2
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-09-17 01:20:03

@Minivanmachoman 

Thank you very much for the updateyes.

 

0
0
#3
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-09-20 19:13:30

@TP-Link, this is definitely a low-tech reply. I had the same problem at one time.  I lived in a rural area.  Turned out that a flock of birds was landing on the wires going up the holler to my house about the same time every day.  Upon investigation, the energy co-op discovered that the wires were old & bare in places.  They replaced the wires.  Birds came and went, but my connection didn't anymore.

2
2
#4
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-09-22 02:19:19

@mbj 

It is an interesting experience and It also provides us some new possibilities.cool

0
0
#5
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-10-11 12:24:21

@TP-Link 

 

I have similar issue - Spectrum is ISP.  Switched from Spectrum provided router to TP-Link a few days ago and I now have frequent drops of internet (before this swsitch everthing worked well, just didn't have the range on the wifi signal that I wanted).  The drops are short in duration, usually just refresh the page and/or close the app an open again, but they are super annoying.  Since the drops are so short (and my router is down in the basement in a not super acceissble locatio) I haven't been able to see if the LED lights turn red, but the log files don't show anything super obvious.  Again, it worked fine a few days ago with a different router, so I do not think it is a line or modem issue.  I don't have Deco, i have Archer C2300.  Do you have recommendation on fix for this TP-Link Archer C2300 paired with Spectrum ISP?

 

I've turned off all the "fancy" features on the new router - Smart Connect, Airtime Fairness, QoS Device Priority.  And set the channels to not auto select (2.4 GHz set to 1, 5 GHz set to 165).  I'm real close to just putting the old Spectrum provide router back in place and returning the TP-Link.

 

Thanks for any help you can provide!

0
0
#6
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-11-29 18:32:26

@TP-Link

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Beta worked for my M5 dropping off Spectrum! Am I supposed to honor update notices now? Or, are those for the regular OS? 

 

 

 

 

 

 

 

 

 

 

2
2
#7
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-11-30 01:43:26

@Tpfan4sure 

Hi,

Do you mean that you get the new firmware notification-1.5.7 on the APP?

You could try to update the firmware via Deco APP when there is a new firmware available.

(And the beta firmware 1.5.0 here for Deco M5 is suitable as long as your current firmware is below 1.6.0)

0
0
#8
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-12-21 00:36:33

@TP-Link the model I have shows 

Model:

W3600(2.0)

 

Can I use the firmware for W3600 V1?

0
0
#9
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2021-12-21 01:22:08

@cmonbux 

Hi, I am afraid that you could not use the beta firmware for V1.

Could you please provide more details about your current issue, like your ISP, and any Deco turn red, so that I can see whether there is a suitable firmware?

Thank you very much.

0
0
#10
Options
Re:[Solution] Main Deco frequently disconnects from the Internet under Spectrum service
2022-01-05 15:13:25

@TP-Link I'm using Frontier Fiber for my ISP and was having this same problem with my Deco x60 v2 using firmware 1.5.1_20210204

 

This beta firmware fixed the frequent disconnect issue for me.  Please make sure it goes into the next official firmware release.

2
2
#11
Options