Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service

Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service

Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2021-11-12 11:26:42 - last edited 2022-06-28 06:08:43
Model: Deco M4  
Hardware Version:
Firmware Version:

Hi All,

Recently, Deco M4(V1&V2) and Deco S4(V1&V2) both have received a new firmware upgrade.

Deco M4-1.5.4-20220113: Click Here to get the Download link.

 

Deco S4--1.5.1-20220113: Click Here to get the Download link.

 

Since they are just released a few weeks ago, some users might not be able to detect the firmware on the APP. In this way, please refer to this link to update the firmware: How to Update the Firmware of Deco (Method 2 via web UI, which does not require internet service to update the firmware as long as the computer is connected to the Wi-Fi of Deco)

*Note: please disconnect the main Deco from the cable modem if you are unable to finish the firmware upgrade.

 

Some important Modifications and Bug Fixes:

1. Fixed the bug that Deco loses Internet connection under some ISP lines, especially for Spectrum and Starhub services. 

2. Fixed the issue that Main Deco is solid white or red, and the wireless clients fail to connect Wi-Fi.

3. Fixed the issue that Satellite Deco disconnects from the main Deco or cannot be added to your network.

 

The engineers highly value any feedback about these two new firmware versions and if you have experienced any issues after the firmware upgrade, please feel free to comment below.

(It would also be highly appreciated if you could also leave me a private message for notification.)

Thank you very much.

  1      
  1      
#1
Options
9 Reply
Re:[Solution] Wireless clients and Satellite Deco fail to connect to Main Deco under Spectrum / Starhub
2021-11-30 18:46:23

@TP-Link This has solved the issues for my setup. Was going crazy yesterday, glad I found this. Thanks for the update!

  2  
  2  
#2
Options
Re:[Solved] Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2022-03-16 09:36:10

  @TP-Link 

Hi, I have 2 Decos M4R at my home. During last months the troubles with disconnection of one of my Decos started. The main one is OK, the troubles I have with the second one. 

It losses the connection. Mostly only restart via cell phone app helps. Sometimes not. 

During the day before yesterday I updated firmware to 1.5.4. The notes to this update mentioned something like these issues should be solved. 

What do you mean? Is it possible that these problems are still caused by some firmware details etc? 

Or should I set something special up in the app?

 

Details: My two Decos are connected via cable. 

 

Thank you very much for help...

  3  
  3  
#3
Options
Re:[Solved] Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2022-04-06 01:12:10
Same exact issues I am having.
WI-Fi Speed Junkie, Destroyer of Dead-Spots & Latency.
  2  
  2  
#4
Options
Re:[Solved] Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2022-04-07 10:39:22

  @The-Burro_1. 

Thank you and would the latest firmware 1.5.4 fix the current issue?

  0  
  0  
#5
Options
Re:[Solved] Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2022-04-11 12:56:22

  @TP-Link This firmware upgrade fixed the problem I worked on all day yesterday including talking with one of your techs. Might have taken 10 mins once I found it to completely fix my problem.

 

Malinart

 

  2  
  2  
#6
Options
Re:[Solved] Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2022-04-12 08:42:02

  @Malinart very useful feedback and Thank you very much.laugh

  0  
  0  
#7
Options
Re:Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2023-04-06 06:53:05

@TP-Link I recently purchased S4 set of 3 router/extender pack. I followed all the steps and connected the 3 routers to the internet and update the firmware to the latest 1.5.1 and I still dont see any internet. When I connect multiple devices and check the Andoird app home page, I only see traffic like 16 to 20kbps and then everything dies and none of my pc/phone's have internet. I noticed that I accidently bought a TP-Link certified refurbished from TPLink directly on Amazon, though I thought it was new.

 

Before I return it I thought I will try to see if you can help fix the problem.

  0  
  0  
#8
Options
Re:Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2023-05-01 01:04:43

  @WebTechie I also have a S4 set from Amazon that has recently experienced very similar issues to what you are experiencing. I wanted to follow up and see if you fixed your issues. 

  0  
  0  
#9
Options
Re:Deco M4/S4 Unstable/No Internet connection Issue under Spectrum / Starhub service
2023-05-01 03:48:25 - last edited 2023-05-01 03:50:15

@jvstin5 No the issue still is the same, on some computers it works fine and then after some time the connection just drops. I am returning it and will try another model or brand.

  0  
  0  
#10
Options

Information

Helpful: 1

Views: 3168

Replies: 10

Related Articles