Great difficulty installing TP Link Archer 7 and repeaters

Great difficulty installing TP Link Archer 7 and repeaters
Great difficulty installing TP Link Archer 7 and repeaters
2022-01-21 19:20:38
Model: Archer A7
Hardware Version: V5
Firmware Version: 5.8

I received a TP Link AC1750 Archer 7 and two TP Link RE450 Repeaters for Christmas. I have been fooling with this setup at least 8-10 hours a day for over a week and I am very frustrated.

I have been using an Apple AirPort Extreme of one model or another for close to 30 years with no problem. All I had to do before was hook it up, set password and security and it worked. 
My router was getting old and weak and I heard good things about the Archer 7. Since trying to hook it up, I am going out of my mind. How can a router be so difficult to hook up?

I finally got it to hook to my internet but couldn't get my printer to work and had the reinstall my Apple router to print some things, and then attempted the install of the Archer 7. With my Appl Airpot Extreme I could configure everything to do with the router on my Mac computer, printer and all with no drivers.

Now I find with the TP Link Archer 7, I have to login to tplink.com to do anything. For someone that is not REALLY computer savvy this can be challenging. I contacted TP Link support and it was almost impossible to communicate with the support people because they can't hardly speak English.

Finally, I was barely able to get the router online but they couldn't tell me how to get my printer to work. Three days later I found that I had to download a driver and install it on my Mac for my HP Printer. I have been using this printer for years while hooked to my Apple routers with no drivers. oK, now the printer is working... or was.

las night, I was attempting to install one of my two new TP Link RE450 Repeaters. I got tired about 2AM and decided to finish today. I started to find my internet was offline, tried resetting my modem and TP Archer 7. Nothing!  I called my internet provider and they reset my modem. Still nothing. I am getting an occasional message saying "TP-Link Installer is not compatible with your Mac". I can't say on here what I am thinking.

None of the equipment I have can be controlled by my Mac, it all has to be done through the TP Link site. While trying to set up the repeaters I saw a message that once I began I couldn't control the repeaters without an app called Tether. I downloaded it and it picked up about 15 different wireless devices.  How in the world am I supposed to know which ones are my repeaters? I think the repeaters are what knocked my off the internet.

when the cable guy got her he said my signal was 245mbs coming out of the modem. My signal at the other end of my house was as low as 1.6 MB's and around 30+ MB's at the router but I could still use a laptop at the other end. With the new Archer 7 I can go to the other end of my house and absolutely NO internet signal.

if someone can tell my how to get this crap working I certainly would appreciate it.

Ed

0
0
#1
Options
1 Reply
Re:Great difficulty installing TP Link Archer 7 and repeaters
2022-01-25 10:01:50

@Hurst01 

 

Hello, I hope you have figured it out to set up the internet on the Archer A7 now. But let me know if it's not.

 

As for the RE450s, you can follow this guide or this one, verify the MAC address if you are not sure which is your RE450, the MAC address is printed on the extender sticker.

0
0
#2
Options