Very slow internet speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Very slow internet speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Very slow internet speed
Very slow internet speed
2023-07-17 21:37:40 - last edited 2023-07-20 20:16:42
Model: Deco X20  
Hardware Version:
Firmware Version: 2.6

I have Spectrum internet that was recently upgraded to 300 Mbps. Unfortunately, the fastest speed I get with Deco is about 100 Mbps which happens to be my "old" speed. I had Spectrum come out to the house to check the system and they got well over 300 Mbps at the modem. I have rebooted both the modem and Deco. I ran a speedtest on a laptop directly connected to Deco with an Ethernet cable and got the same roughly 100 Mbps speed. Deco is Firmware 1.2.0, hardware version 2.6. The Deco app says everything is up to date. I am very frustrated and would appreciate any help.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Very slow internet speed-Solution
2023-07-18 07:06:05 - last edited 2023-07-20 20:16:42

  @trmoore 

Hi, welcome to the community.

Here are some possible suggestions:

1. replace the Ethernet cable between cable modem and Deco. A new good quality cat5e cable would be great.

2. check whether the QOS under Deco APP>More>QOS to be capped at 100 m/s download and upload. change it to 500 m/s download/upload if possible.

3. disable UPNP under Deco APP>More>Advanced>NAT forwarding.

 

 

If nothing helped, please do get back here so that we could check together what might be the problem.

Best regards.

Recommended Solution
  0  
  0  
#2
Options
3 Reply
Re:Very slow internet speed-Solution
2023-07-18 07:06:05 - last edited 2023-07-20 20:16:42

  @trmoore 

Hi, welcome to the community.

Here are some possible suggestions:

1. replace the Ethernet cable between cable modem and Deco. A new good quality cat5e cable would be great.

2. check whether the QOS under Deco APP>More>QOS to be capped at 100 m/s download and upload. change it to 500 m/s download/upload if possible.

3. disable UPNP under Deco APP>More>Advanced>NAT forwarding.

 

 

If nothing helped, please do get back here so that we could check together what might be the problem.

Best regards.

Recommended Solution
  0  
  0  
#2
Options
Re:Very slow internet speed
2023-07-19 01:49:04

  @David-TP 

 

Thanks, David. New Ethernet cable is on the way and I will check those settings. 

  0  
  0  
#3
Options
Re:Very slow internet speed
2023-07-20 20:16:20

  @trmoore David, thanks for the suggestions. I think it was the QOS limits that were limiting my speed. I am now getting over 300 Mbps and that is without adding newer Ethernet cables!

 

Thanks!!

  3  
  3  
#4
Options

Information

Helpful: 0

Views: 644

Replies: 3

Related Articles