HS100 Amber/red only Wi-Fi LED (FIXED)

HS100 Amber/red only Wi-Fi LED (FIXED)
HS100 Amber/red only Wi-Fi LED (FIXED)
2021-03-16 11:50:22 - last edited 2021-03-24 16:27:20
Model: HS100-KIT
Hardware Version: V1
Firmware Version: 1.2.6

Hey!

 

While encountering this issue and browsing the web for solution ending with "contact support for RMA". As this product already was out of warranty for me I didn't even try to waste my time and instead tried to find other solutions before disassembling it. After a few days of trial and error it worked, this might not help everyone but hopefully helps some just to lessen the e-waste.

 

Cause:

Spammed on/off repeatedly from KASA-app and device got unresponsive.

 

Problem:

Power plug has amber "Wi-Fi LED" only and unresponsive to RESET with pressing and holding the "Settings Button", leaving it overnight un/plugged did nothing.

 

Behavior:

Wi-Fi LED - Amber only and after 20-30 seconds it will turn off and go back to amber only, my guess it's rebooting and stuck in this loop (bootloop).

Power LED - Unresponsive the first 3-5 seconds but after that can be turned ON and OFF. If turned ON then it will turn OFF every time "Wi-Fi LED" turns off.

Settings Button - Unresponsive and "Wi-Fi LED/Power LED" behavior continues.

 

Solution:

- Hardware reset with pressing and holding "Settings Button" but it needs to be pressed at the right time or it will not register and continue the bootloop.

The right time?

It is hard to say when exactly but from what I remember it was a 1-2 seconds after the "Power LED" could be turned ON and I held "Settings Button" for around 10 seconds. My guess is if it's any earlier than that the device hasn't booted up and it does not register the button being held even after it starts up. Any later than that the window to initiate factory reset ends because device reboots.

 

Potential manufacturer fix:

Increase devices time before it reboots and make it clear to wait around 10 seconds before holding "Settings Button" or it will not register it.

 

 

3
3
#1
Options