Deco M4 slow speeds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M4 slow speeds
Deco M4 slow speeds
2021-03-29 00:02:40
Model: Deco M4
Hardware Version: V2
Firmware Version: 1.4.3 Build 20200918 Rel. 74289

I just bought the Deco M4 mesh kit with 2 nodes. The main Deco is in the living room, connected to my ISP router via Ethernet cable, and the second is in the hallway about 8m (26ft) away, with a direct line of sight from the main one (no obstacles in between), connected wirelessly. My laptop (Macbook Pro) is in the office, about 6m (20ft) from the hallway Deco, with direct line of sight towards it. Think of the layout as an "L" shape, where the main Deco is at the top of the L, the second Deco is at the knee and the laptop is at the bottom end. All devices are about 1m (3.3ft) from the ground.

 

My internet speed is 250 Mbps, but my laptop only gets around 15 Mbps, and very unstable. I've tried many different placements for the Decos, but this is the best I've achieved in terms of connection stability and speed.

 

Testing the speeds via Fast.com:

Connected to the ISP router wifi network, standing next to it: 250 Mbps
Connected to the main Deco, standing next to it: 120 Mbps

Connected to the main Deco, standing about 6m (20ft) from it: 80Mbps

Connected to the hallway Deco, standing next to it: 120 Mbps

Connected to the hallway Deco, in the office about 6m (20ft) from it: 5 Mbps

 

I checked Wireless Diagnostics on the laptop, and the hallway Deco's RSSI is at -51, which is a decent signal strength.

 

When in the office, both my phone and my laptop constantly get disconnected from the network, and speeds are very slow. My apartment has only one floor, and 120m² (1,290ft²) – it shouldn't be this complicated. Why am I not getting the full 250 Mbps when standing next to the Decos, and why is the connection and speed dropping so much in such a short distance from the second Deco? I can still pick up the main Deco signal from the office, though the strength is much weaker than the hallway Deco – could this be interfering with the connection?

0
0
#1
Options
3 Reply
Re:Deco M4 slow speeds
2021-03-29 02:42:49

@jpfaraco 

Hi, Did the Deco M4 work as the access point or router mode?

And did Deco have the same SSID as the ISP router?

Have you tried to turn off the 2.4ghz on the Deco temporarily and check whether the 5ghz speed is also slow?

By the way, except for the Macbook Pro, how about other mobile devices?

 

Thank you very much.

 

 

0
0
#2
Options
Re:Deco M4 slow speeds
2021-03-29 04:53:21

@TP-Link Hey! 
It was in router mode initially, but I switched to access point mode to see if anything changed. I'm still not sure what the best option would be, but neither improved the internet speed in the office.

 

I gave the Deco a different SSID from the ISP router and set the devices to forget the ISP router wifi credentials, so they don't automatically connect to it instead of the Deco network.

 

Apart from the Macbook, I have a Google Pixel 4 phone and a Roborock S5 robot vacuum, both of which need good wifi coverage around the house. Right now the phone is in the office and is connected to the Deco network (I'm not sure which one, though) but it appears as "offline" in the device list in the Deco app. I also have a Chromecast connected to the TV in the living room, which is working perfectly – I can connect to it and cast content to it – but it also appears as "offline" in the device list in the Deco app. Refreshing the list has no effect. Running the speed test on the phone returns the same result as on the laptop.

 

I turned off 2.4Ghz but the speed is the same – around 5Mbps in the office. 

 

I did another speed test, connected to the hallway's 5Ghz band, and got 250Mbps. However, as soon as I step into de office, which is 6 paces in a straight line from the hallway Deco, the devices switch to 2.4Ghz and speeds drop to 5Mbps.

0
0
#3
Options
Re:Deco M4 slow speeds
2021-07-31 20:28:50

@jpfaraco Hello, same problem here. I have changed all kind of configurations, nothing improve. I believe that all those Deco are not good option and it was money in the trash.

 

Could you resolve the problem?

 

Regards

0
0
#4
Options