My camera (C420) won't reset

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

My camera (C420) won't reset

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
My camera (C420) won't reset
My camera (C420) won't reset
2022-12-22 19:52:45 - last edited 2023-12-14 09:16:24
Tags: #Firmware #Broken
Model: Tapo C420S2  
Hardware Version: V1
Firmware Version: 1.2.0

Hi,

It seems like I'm the the first one experiencing this problem. The problem is though that it started with my camera saying it died, then saying it needed to reset, which I couldn't be able to. I click the "Sync/Reset" button and it flashes faster sometimes, but after waiting 30 seconds, as intended, it keeps on flashing the colour red.

Is my camera broken? Do I need a replacement?

 

Please help.

Thank you.

  6      
  6      
#1
Options
1 Accepted Solution
Re:My camera (C420) won't reset-Solution
2023-01-05 07:25:58 - last edited 2023-12-14 09:26:48

Update on Dec 14, 2023.

 

Hello everyone, 
Thank you very much for the case report.

 

For the phenomenon where the Status LED on the Tapo C420/C400 camera keeps flashing red, and there is no response when pressing the SYNC/RESET button, it is recommended to try the:

1) Remove the battery from the camera, wait for 10 seconds, reinsert the battery on the camera, and wait for 2 minutes.

2) Then press the SYNC/RESET button on the camera again to see if there is any change in the Status LED.

To reset the Tapo C420/C400(How to reset my Tapo camera?):
1. Twist anti-clockwise and then pull to remove the cover of the camera and find the reset button.
2. Press and hold the SYNC/RESET Button for at least 5 seconds.

 

If the Status LED has no change, please send a private message to @Solla-topee(Make sure you've registered or logged in with your TP-Link ID in our community first) with the format "Forum ID 593222+ camera's model number + Status LED on the camera keeps flashing red" and the following information for further assistance.
1. The MAC address of the camera.
2. Confirm if the camera is a brand new product, and what happened to the camera so it has the problem if it worked.
3. A video shared link of the issue if possible.

 

Best Regards
 

Recommended Solution
  0  
  0  
#8
Options
18 Reply
Re:My camera (C420) won't reset
2022-12-23 01:21:45 - last edited 2022-12-23 01:29:44

  Hello @yeremeshy 

Thank you for reaching out to the community!

Please reboot the camera, wait the camera to be stably on, then ensure you  reset the Tapo C420 as the UG here.

Factory reset Tapo C420 :Press and hold "Sync/Reset"  button for about 5 seconds to reset the camera

 

May I know will the camera keep flashing red after the factory reset?  Prior to the issue happens,  was there any power outage or firmware update failure, thank you 

 

  0  
  0  
#2
Options
Re:My camera (C420) won't reset
2022-12-23 09:21:00

  @Solla-topee 

 

As of now, I only know that the battery died, and it wasn't 180 days yet.

It does sometimes flash red after 3 seconds, but then doesn't do anything after that.

This is the camera as of now:

 

Solla-topee wrote

  Hello @yeremeshy 

Thank you for reaching out to the community!

Please reboot the camera, wait the camera to be stably on, then ensure you  reset the Tapo C420 as the UG here.

Factory reset Tapo C420 :Press and hold "Sync/Reset"  button for about 5 seconds to reset the camera

 

May I know will the camera keep flashing red after the factory reset?  Prior to the issue happens,  was there any power outage or firmware update failure, thank you 

 

 

  0  
  0  
#3
Options
Re:My camera (C420) won't reset
2022-12-26 10:55:21 - last edited 2023-01-15 09:20:10

  Hello  @yeremeshy 

 

Thank you,   please get the camera battery charged first, then please check  see if the Led flash orange and green after a factory reset.

 

If the issue persists, can you share a video clip of the issue with us, you can share via drivelink like  Googledrive link with by PM or the support email. 

When did you purchase the camera?  

We created a support email TKID221246721  for your case to better assist with the issue, please check your email inbox. 

  0  
  0  
#4
Options
Re:My camera (C420) won't reset
2022-12-26 18:13:58

  @Solla-topee 

 

I'll send you an email after the camera fully charges. But for now, we bought the TP-Link Camera C420 on the 25th of November, this year, and received it on the 29th. We bought the camera's in a pack of two, but fortunately, only one of them stopped working.

 

Solla-topee wrote

  Hello  @yeremeshy 

 

Thank you,   please get the camera battery charged first, then please check  see if the Led flash orange and green after a factory reset.

 

If the issue persists, can you share a video clip of the issue with us, you can share via drive link like  Google drive link with by PM or the support email. 

When did you purchase the camera?  

We created a support email TKID221246721  for your case to better assist with the issue, please check your email inbox. 

 

  0  
  0  
#5
Options
Re:My camera (C420) won't reset
2022-12-28 01:27:46 - last edited 2022-12-28 01:48:32

Hi   @yeremeshy 

Thank you! Feel free to let us know how it goes on the support email TKID221246721  or here on the community. 

If you continue to face the problem, a video shared link of the Led status on camera (after reset) is much appreciated 

 

  0  
  0  
#6
Options
Re:My camera (C420) won't reset
2023-01-05 04:47:13

  @Solla-topee Same goes for me, after I charged it, it just blinking red. Here is my Google link for the video proof. https://drive.google.com/file/d/1ilH1HVAsI_hE0xmGgEaGWqsSyUEHKdMJ/view?usp=drivesdk

  4  
  4  
#7
Options
Re:My camera (C420) won't reset-Solution
2023-01-05 07:25:58 - last edited 2023-12-14 09:26:48

Update on Dec 14, 2023.

 

Hello everyone, 
Thank you very much for the case report.

 

For the phenomenon where the Status LED on the Tapo C420/C400 camera keeps flashing red, and there is no response when pressing the SYNC/RESET button, it is recommended to try the:

1) Remove the battery from the camera, wait for 10 seconds, reinsert the battery on the camera, and wait for 2 minutes.

2) Then press the SYNC/RESET button on the camera again to see if there is any change in the Status LED.

To reset the Tapo C420/C400(How to reset my Tapo camera?):
1. Twist anti-clockwise and then pull to remove the cover of the camera and find the reset button.
2. Press and hold the SYNC/RESET Button for at least 5 seconds.

 

If the Status LED has no change, please send a private message to @Solla-topee(Make sure you've registered or logged in with your TP-Link ID in our community first) with the format "Forum ID 593222+ camera's model number + Status LED on the camera keeps flashing red" and the following information for further assistance.
1. The MAC address of the camera.
2. Confirm if the camera is a brand new product, and what happened to the camera so it has the problem if it worked.
3. A video shared link of the issue if possible.

 

Best Regards
 

Recommended Solution
  0  
  0  
#8
Options
Re:My camera (C420) won't reset
2023-01-15 00:10:47

 Hi all. Glad I'm not the only one with this issue, but is very worrying how many others have the issue. Sounds like a big Tapo/TP-Link fault. 
 

got these pair of cameras just before Christmas. Both installed same day. After one week, Camera 1 battery went from 70% to dead overnight and then after a full battery charge only ever flashes red and will not reset. Tried rebooting hub, inserted Camera 2 battery as a test as well and still same issue so I deleted camera 1 from the list to reinstall and can't add it back to my devices as the hub can't find it to connect anymore.
 

Then 3 weeks later Camera 2 went from 30% to dead overnight (but up to this point the battery had lasted 5 weeks so was quite surprised). But now same issue. Charged battery 2 and reinserted and exactly the same flashing red as when Canera 1 battery was replaced. 
the weird thing is when the battery was reinserted in camera 2, on the app it showed the updated battery percentage in the list of devices but it won't stop flashing red, the live feed never loads and it won't reset, so it knows the battery is charged but won't actually go into live or record mode anymore. Or reset. Or work at all so two dead cameras. Rebooting hub doesn't make a difference and checking the hub status it says connection is good. 
very upset that all it took was the battery dying to break both cameras. 
bought in the UK in December 2022 and have done all firmware and APP updates. 

  1  
  1  
#9
Options
Re:My camera (C420) won't reset
2023-01-16 11:27:20

  @Georgiams 

Thank you for sharing the case details!  

For C420 flashing red led, if a factory reset does not help, it is recommended to reach us via the email mentioned above, our support will continue to help and may need to start the RMA process.

Sorry for the trouble, and thank you for your time in reporting the issue. 

  0  
  0  
#10
Options
Re:My camera (C420) won't reset
2023-02-11 11:21:18

  @Solla-topee 

I am absolutely fuming...I have just been through the RMA process and received my replacement set. I installed both cameras on Thursday (they have been working fine since) and am gutted that today (Saturday morning...less than 48hours since installation) that one of the cameras has done the exact same and won't load the live view and is just flashing red. I have rebooted both the camera and the hub and the battery status is staying up to date so it is still connected to the hub in some way, it was showing 93% when it first froze. I then plugged it in to charge and the app reflected the charging status and subsequent 100%. 
 

I have tried a hard reset of the camera and it just continues flashing red. Exactly the same as the last set. This is ridiculous that now two sets have exactly the same issue. If it is a hardware issue the product should not be being sold anymore and full refunds offered. 
 

if it is a software issue I would ask that you investigate when a firmware update will be released to address this as I am not going through the RMA process again as that is a waste of my own time and money. 

  1  
  1  
#11
Options

Information

Helpful: 6

Views: 2214

Replies: 18

Tags

Firmware
Broken
Related Articles