ONVIF Motion detection broken

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

ONVIF Motion detection broken

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ONVIF Motion detection broken
ONVIF Motion detection broken
2023-08-03 16:30:43 - last edited 2023-11-01 02:53:16
Model: Tapo C200  
Hardware Version: V2
Firmware Version: 1.3.6

Hello,

 

The ONVIF integration of Tapo cameras into a third party systems like Skrypted, Home Assistant and NVRs is one of the main features the product to be purchased. At least I have bought 7 cameras because of this. 
 

Tapo team is well aware there is a problem with the ONVIF motion detection after the latest firmware updates on almost all camera models. The problem is here for months. Some of the most skilled developers from Scrypted and Home Assistant communities are trying to find a workaround but it is impossible because the problem is buried too deep into the buggy firmware release.

 

I have spend hours to read the post in the community here, an I can see a lot of complaints. Regardless of the problem, the support is always pushing in the direction "disconnect the NVR, we don't support HA" kind of "solutions".
 

Tapo cameras  are listed as ONVIF compatible, but currently they are not! Take the problem seriously, as you have already lost the trust of the customers enough, and a lot of them are ready to switch to different manufacturers.
 

 

 

 

  5      
  5      
#1
Options
1 Accepted Solution
Re:ONVIF Motion detection broken-Solution
2023-09-14 09:27:22 - last edited 2023-11-01 02:53:16

  @Santorius 

 

Update of the firmware for Tapo C200 (hardware version 2.0 and 3.0) was released yesterday, and now Motion Detection over ONVIF with Scrypted is working FLAWLESSLY! Update with the fix is expected for C100 too!

 

I wish to express my gratitude to Tapo support Team, and their engineers, for not giving up, and their patience. Great work, well done! 

Recommended Solution
  0  
  0  
#11
Options
12 Reply
Re:ONVIF Motion detection broken
2023-08-04 07:40:44

  @Santorius 

Hi,
Thank you for your case report, and we are keeping handling the user-reported issues actively. For your ONVIF motion detection problem, please help collect the following information first to know your detailed problem phenomenon.

 

1. Please ensure the Tapo cam is up to date, and the motion detection feature on the camera is no problem.
How to use motion detection function of my Tapo camera in Tapo app?

2. Please describe your network diagram and usage scenario in detail. For example, how does your camera connect to go to the internet, how do you stream the camera via ONVIF protocol, locally or remotely, what's the third party system, what's the model number of the NVR/NAS, etc?

 

Best Regards

  0  
  0  
#2
Options
Re:ONVIF Motion detection broken
2023-08-04 09:51:31

  @Solla-topee 

 

Thank you for your reply.

 

Everything was working on my Tapo C200 cameras with firmware 1.3.3. Currently the cameras which are updated, ONVIF motion is not working, but on the one which I didn't update (still on 1.3.3) everything is working fine. All the cameras are using the same network, account setup etc. The problem is the same for Home Assistant, Scrypted and Homebridge.

 

I would advise you to follow up the information in the links below. Those links are just a few of the examples you can very easy find if you just Google the problem - it started in April!
 

https://github.com/home-assistant/core/issues/91661
 

https://github.com/JurajNyiri/HomeAssistant-Tapo-Control/issues/312
 

https://github.com/koush/scrypted/issues/796
 

https://github.com/koush/scrypted/issues/836
 

https://github.com/home-assistant/core/issues/91661
 

https://github.com/home-assistant/core/pull/92627
 

The community has been doing you a favour. You will find months of work on the problem, hundreds of tests and logs.

  1  
  1  
#3
Options
Re:ONVIF Motion detection broken
2023-08-08 08:34:18 - last edited 2023-08-08 08:37:46

  @Santorius 

Hi,
Thank you for your feedback. As we know, different users may have the same problem phenomenon, but it's hard to say the root that causes the problem is the same since the network diagram, usage scenario, and client devices are different. If you are willing to troubleshoot, I hope you can provide detailed information to locate the problem. Thank you in advance!

1. Is your network diagram the Internet--wireless router)))Tapo Cameras?

 

2. How do you stream the camera via ONVIF? For example, you have installed a third-party app on a computer in the same network as the camera to stream the camera via ONVIF.
If so, please let me know what app installed on your computer and the version of it.

If not, please describe your usage scenario in detail. To simplify the issue, you can use the Home Assistant as an example. I'll then forward your case to the tech team to reproduce the problem if needed, and any information you provide is highly appreciated! 

 

3. Just double confirm, is the problem that the Tapo app received the motion-detected notification of a Tapo C200 with version 1.3.6, but the app used to stream the camera via ONVIF does not receive it? If so, please ensure the app has enabled the notification permission for this Tapo C200.

 

Best Regards

  0  
  0  
#4
Options
Re:ONVIF Motion detection broken
2023-08-08 10:31:52

  @Solla-topee 

 

Hello,

 

ok, let me give you the information you asked, and see what will happen.

 

Connectivity:

 

1Gbs Internet connection via optical to Ethernet adapter, connected to eero router. 
Cameras connected via WiFi,

Scrypted running on MacOS Ventura on a Mac Pro, connected via Ethernet 1Gbs.

There are no any restriction on the network, no vlan, no double Nat, only one SSID. 

 

Cameras:

 

Tapo C200 1.3.3 x1

Tapo C200 1.3.6 x2

 

Integration:

Scrypted via ONVIF

 

The current setup was working fine for months. Motion detection via ONVIF in Scrypted stopped working after updating 1 of the cameras to 1.3.6. The camera was working properly if used with Tapo app. To replicate the problem, I have updated second Tapo C200 to 1.3.6. The ONVIF motion in Scrypted stopped working immediately.

 

Curently the camera with firmware 1.3.3 is working without any problems in Scrypted via ONVIF, while both cameras with firmware 1.3.6 do not report motion to Scrypted.

 

  0  
  0  
#5
Options
Re:ONVIF Motion detection broken
2023-08-09 11:32:13

  @Santorius 

Hi,
Thank you for your detailed information, and I have one more question: Is the motion detection feature for the Tapo C200 with firmware 1.3.6 working on the Tapo app?
If not, please refer to the link below to troubleshoot.
Motion Detection Is Not Working On TP-Link Camera
 

Best Regards

  0  
  0  
#6
Options
Re:ONVIF Motion detection broken
2023-08-09 12:42:05

  @Solla-topee 

 

yes, everything is working on Tapo App

  0  
  0  
#7
Options
Re:ONVIF Motion detection broken
2023-08-10 06:38:08

  @Santorius 

Hi,
We have reported the issue to the tech team, and they will likely reach out to you via email to continue troubleshooting your issue. Please check your email box and confirm.
Best Regards

  0  
  0  
#8
Options
Re:ONVIF Motion detection broken
2023-08-23 12:10:24

  @Solla-topee 

One partial solution for the people with this problem (all the HomeAssistant comunity) could be as simple as let us the posibility to downgrade our firmware to a previous working version.

I actually use 2 C110 and 1 C310 cameras that stop working motion after update.

Thanks in advance

  1  
  1  
#9
Options
Re:ONVIF Motion detection broken
2023-08-23 12:45:08

  @Joe7045 

 

I completely support that idea. Having in mind that an engineer from Tapo is having difficulty to replicate the problem (how so?????), if they don't fix the problem, the solution for

me will be either to be allowed to downgrade the firmware (even for newly purchased cameras), or I will have to consider to switch to another brand like Aqara, with native HomeKit support.

  0  
  0  
#10
Options
Re:ONVIF Motion detection broken-Solution
2023-09-14 09:27:22 - last edited 2023-11-01 02:53:16

  @Santorius 

 

Update of the firmware for Tapo C200 (hardware version 2.0 and 3.0) was released yesterday, and now Motion Detection over ONVIF with Scrypted is working FLAWLESSLY! Update with the fix is expected for C100 too!

 

I wish to express my gratitude to Tapo support Team, and their engineers, for not giving up, and their patience. Great work, well done! 

Recommended Solution
  0  
  0  
#11
Options

Information

Helpful: 5

Views: 1139

Replies: 12

Related Articles