Tapo C520WS ONVIF motion detection not working

Tapo C520WS ONVIF motion detection not working

Tapo C520WS ONVIF motion detection not working
Tapo C520WS ONVIF motion detection not working
2024-05-07 22:34:50 - last edited 2024-06-07 03:28:29
Model: Tapo C520WS  
Hardware Version: V1
Firmware Version: 1.2.7

Hello.


I am using Tapo C520WS connected to QVR Pro 2.5 of QNAP TS-264.
I've tried various things and ONVIF motion detection doesn't seem to work.
Of course, motion detection is turned on in the Tapo app, and I have confirmed with QNAP support that the settings on QNAP QVR Pro are correct.

 

According to QNAP support, it is a problem on the TP-LINK side.
Is it possible to fix the ONVIF motion detection problem with a firmware update?

 

Below is the email I received from QNAP Support.

 

"After checking with the internal camera integration department, it was found that some TP-Link cameras have compatibility issues with the ONVIF standard, leading to motion detection not working on third-party NAS systems via ONVIF. This is why these camera models are not listed in the QNAP camera compatibility list, as camera integration for those TP-Link cameras was halted due to these compatibility issues with motion detection via ONVIF.

 

Therefore, our engineer recommends that you report this issue to the TP-Link camera manufacturer and inquire if any new firmware is available to resolve the problem. "

 

thank you.

  8      
  8      
#1
Options
1 Accepted Solution
Re:Tapo C520WS ONVIF motion detection not working-Solution
2024-06-06 22:35:40 - last edited 2024-06-07 03:28:29

Hi,

 

I helped test the beta firmware and was able to confirm that ONVIF motion detection works properly in the beta version.
I would like to express my sincere gratitude to the technical support engineers.

The official firmware is scheduled to be released around July 2024.

 

Best Regards

Recommended Solution
  1  
  1  
#8
Options
11 Reply
Re:Tapo C520WS ONVIF motion detection not working
2024-05-08 09:25:11

  @jp_kyoto 

Hi,
It's hard to say the problem is on the Tapo camera for the reported case. Please help confirm the following information for further analysis.

1.  Is the motion detection feature working when using the Tapo app?

2. Can you watch the camera's live feed on the third-party program QNAP QVR Pro via the ONVIF connection?

Best Regards

  0  
  0  
#2
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-05-08 21:35:30

  @Solla-topee 

 

Thank you for your reply!

 

>1.  Is the motion detection feature working when using the Tapo app?
Yes. The motion detection feature is working in the Tapo app.

Tapo app

 

 

>2. Can you watch the camera's live feed on the third-party program QNAP QVR Pro via the ONVIF connection?
Yes. Camera's live feed displays correctly in QVR Pro and QVR Pro Client.
The pan/tilt function also works properly.

QVR Pro settings screen

 

QVR Pro Client

 

I have 3 Tapo C520WS, but motion detection doesn't work on all of them.

 

thank you.

 

 

  0  
  0  
#3
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-05-09 08:08:14

  @jp_kyoto 

Hi,

I have reported the case to the tech team, and they will likely reach out to you via email to continue troubleshooting your issue. Please check your email box and confirm.

Best Regards
 

  0  
  0  
#4
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-05-16 00:10:38

  @Solla-topee 

Hi,

 

I am also running into the same problem with the C520WS, so I just wanted to add my findings here as well.  I have 5 Tapo cameras (two C110, two C210, and one C520WS), and I recently set up Shinobi on my Raspberry Pi to monitor them for ONVIF events.  All 5 are able to transmit RTSP streams with no problems.  While the C110 and C210 cameras are also able to send ONVIF motion detection events as expected, the C520WS is not successfully sending motion events (events do show up in the Tapo app, however).

 

Just to make sure it was not a configuration problem with Shinobi, I also tried connecting to the C520WS using the Javascript package, node-onvif-events, as well as with "ONVIF Device Manager", and both fail to receive events as well, even though they can connect to one of my C210 cameras that I also tested and receive motion events from the C210.  node-onvif-events seems to fail with a "connection reset" exactly 10 seconds after the "PullMessage" request is sent to the C520WS, while ONVIF Device Manager reports the following:

I look forward to hearing a solution for this, whether it's new firmware or just some setting we need to do in the camera's configuration!

 

Thanks,

Roy

 

  3  
  3  
#5
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-05-16 04:43:16 - last edited 2024-05-16 04:44:11

 Hi,
 

I've the same issues as well. I've 4 Tapo camera C520WS, C320WS, C210, C100. 
 

C520WS & C320WS not able to trigger the QVR Pro event record when there's motion detected from the Tapo app.
 

Another two C210 & C100 no issues, working as intended. 

  5  
  5  
#6
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-05-22 06:41:51

  @CallMeKelv  @rvarg 
Hi,
I have reported the case to the tech team, and they will likely reach out to you via email to continue troubleshooting your issue. Please check your email box and confirm.
Best Regards

  0  
  0  
#7
Options
Re:Tapo C520WS ONVIF motion detection not working-Solution
2024-06-06 22:35:40 - last edited 2024-06-07 03:28:29

Hi,

 

I helped test the beta firmware and was able to confirm that ONVIF motion detection works properly in the beta version.
I would like to express my sincere gratitude to the technical support engineers.

The official firmware is scheduled to be released around July 2024.

 

Best Regards

Recommended Solution
  1  
  1  
#8
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-06-07 03:28:59

  @jp_kyoto Thank you for the case sharing~ 

  0  
  0  
#9
Options
Re:Tapo C520WS ONVIF motion detection not working
2024-06-07 18:25:22

  @jp_kyoto 

 

I also had a chance today to play with the new firmware on the C520WS.  While I am able to see events now in ONVIF Device Manager, including separate notices of motion vs. person, my particular issue, which affects the Shinobi recording software that I use, is still there, and I have followed up with details to the tech.

 

  0  
  0  
#10
Options
Re:Tapo C520WS ONVIF motion detection not working
Sunday

  @jp_kyoto Hello. I have purchased two C520WS and installed the newest firmware available 1.2.8, but the motion detection on the cameras does not trigger QVR PRO event. I had to revert to QVR handling the motion detection, but obviously the resolution has to be set to full HD. What did you do to gest it working? My cameras are set as ONVIF and profileS. Thanks for any support or idea you cold provide.

  0  
  0  
#11
Options

Information

Helpful: 8

Views: 1878

Replies: 10

Related Articles