Slow speeds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Slow speeds

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Slow speeds
Slow speeds
2020-09-27 04:13:03 - last edited 2020-09-27 07:15:16
Model: Archer C5400X  
Hardware Version: V1
Firmware Version: 1.1.2 Build 20191223 rel.73956(5553)

I just set up my router after moving. I have Xfinity 600mbps internet. Directly connected into the router and over wifi Im only able to get 91mbps MAX. Ive tried all the advice that Ive found on here and nothing has worked. Ive tried the beta Firmware and still the same slow speeds. I can plug into the back of the modem and get 600+mbps. Plug the router back in and back down to 91mbps. I used the router with another provider before Xfinity without issues. I see that for the Internet Negotiation speed for the internet port is only 100mbps full. How do I change that? Ive tried different cables.

  0      
  0      
#1
Options
3 Reply
Re:Slow speeds
2020-09-27 14:48:00

 

Cheezzburgr wrote

I just set up my router after moving. I have Xfinity 600mbps internet. Directly connected into the router and over wifi Im only able to get 91mbps MAX.

@Cheezzburgr 

 

Since 'wired' and 'wireless' get the same speed that rules out the devices and the cable from router to a device.

 

Cheezzburgr wrote

I can plug into the back of the modem and get 600+mbps.

 

OK, so I'll assume it is the SAME device that was wired via the router and it now gets full speed?

 

Cheezzburgr wrote

Plug the router back in and back down to 91mbps. I used the router with another provider before Xfinity without issues. I see that for the Internet Negotiation speed for the internet port is only 100mbps full. How do I change that? Ive tried different cables.

 

Well, that would indicate either a modem or cable problem. Could be a cable if it isn't Cat 5 or better though.

 

What I'd try is power cycle modem and router, modem on firrst and when up, then power on the router. It is possible the modem has 'held' the settings for the wired device and that is why it works. Some modems will only fully connect to the last device it was connected to. On a power off it loses that device memory and will connect to the new device it sees on power up.  Sometimes it is the ISP that locks the device MAC Address to the modem. You should be able to CLONE the wired device MAC address to the Router via the Advanced settings for Network if the rebooting doesn't solve it.

  0  
  0  
#2
Options
Re:Slow speeds
2020-09-27 20:12:46
SO when I look at the Negotiation Speed, the internet port is only 100Mbps Full Duplex. Ive used different cables from my modem to the router. Im using a CAT6 cable now that was able to get 700Mbps right from the modem. Why is it only 100Mbps? my modem is the Arris SB8200. Ive tried restarting the modem and waiting until thats up and starting up the router but still only 100Mbps.
  0  
  0  
#3
Options
Re:Slow speeds
2020-09-28 14:36:32

@Cheezzburgr 

Cheezzburgr wrote

SO when I look at the Negotiation Speed, the internet port is only 100Mbps Full Duplex. Ive used different cables from my modem to the router. Im using a CAT6 cable now that was able to get 700Mbps right from the modem. Why is it only 100Mbps? my modem is the Arris SB8200. Ive tried restarting the modem and waiting until thats up and starting up the router but still only 100Mbps.

 

What is the cable between the modem and router? Cat 6?

 

If your modem to router cable is 'good', then you should get better than 100Mbps?

 

On my A20 Router on the Status page which I assume is how you see that too.

 

So if the cable is Cat 5e or 6, then look at the WAN port, could be a pin problem, not making contact well, or something else. In any event a call to Support might be your best option.

  2  
  2  
#4
Options

Information

Helpful: 0

Views: 343

Replies: 3

Related Articles