PPTP VPN Passthrough not working

PPTP VPN Passthrough not working
PPTP VPN Passthrough not working
2021-02-25 21:53:15
Model: Archer A7
Hardware Version: V5
Firmware Version: Archer A7(US)_V5_210125

The ability to connect to my workplace PPTP VPN stopped working yesterday even though I haven't made any changes to the router. The VPN connects fine with the computer plugged directly to my cable modem. Does anyone have an idea what might be causing this, or is anyone else experiencing the same issue?

 

Here are the things I have tried so far:

- rebooted router

- verified that PPTP passthrough was enabled

- updated firmare

- reverted to older firmware: Archer A7(US)_V5_201029

- turned off SPI firewall

- turned on DMZ and pointed it to LAN IP of my computer

- factory reset the router and set it up again manually without using a backup of the settings

 

Thanks!

 

0
0
#1
Options
4 Replies
Re:PPTP VPN Passthrough not working
2021-03-01 23:02:26

@Volvstang 

 

If nothing changed on the router end, then something changed on the opposite end. 

 

Go to Advanced > NAT Forwarding > ALG, and make sure PPTP passthrough is enabled. 

 

If that still does not work, create the PPTP connection on the actual device rather than the router which should then work.

0
0
#2
Options
Re:PPTP VPN Passthrough not working
2021-03-02 00:27:08

@Tony PPTP passthrough is enabled, and the PPTP connection is being initiated by devices behind the router, not the router itself. I was suspicious of the ISP changing something on their end, but when a computer is plugged directly into the cable modem the VPN connects without issue.

 

Today I popped in a switch between the cable modem and the router and used a second laptop to run a Wireshark on the LAN and WAN sides of the router simultaneously and it appears the the GRE packets are not making through the router. Without a firmware change, I have no idea what could have caused this to stop working.

0
0
#3
Options
Re:PPTP VPN Passthrough not working
2021-03-03 00:00:49

@Volvstang 

 

If possible, you could try factory resetting the router (hold reset for 15 seconds), then reflash the current latest firmware if the config file somehow changed or got corrupted.

0
0
#4
Options
Re:PPTP VPN Passthrough not working
2021-03-03 21:13:18

@Tony I tried that without any success, so I went ahead and put a new router in and it fixed the issue. I'll get an RMA going on the old one. Thanks for your help.

0
0
#5
Options