TG-3468 not working after startup, only after restart

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TG-3468 not working after startup, only after restart
TG-3468 not working after startup, only after restart
2022-01-09 08:38:57
Model: TG-3468
Hardware Version: V4
Firmware Version: 1168.3.1022.2021

Hi. I have a TG-3468 Ethernet adapter which works really strange on my Windows 11 PC. If I shutdown the computer, and the startup again, it will not be recognized by the PC. It's not in the Device Manager. But if I then restart, it works. This happens every time. The driver version I have is 1168.3.1022.2021 (don't know the firmware version), which I got from Realtek. I also tried with the one in the support page here at TP Link, but that didn't solve the problem. Any ideas?

0
0
#1
Options
4 Reply
Re:TG-3468 not working after startup, only after restart
2022-01-11 07:20:41 - last edited 2022-01-11 07:21:55

Hello @eirismania 

Thank you for your detailed post. 

May I know did the TG-3468 work fine with Win10 computer before, do you mean the the PCI adapter will show up in device manager  after a PC restart?

 

If the adapter not recognized by PC (disappear from Device Manager) from time to time, please try some suggestions in Case2 in the FAQ below: 

What should I do if I cannot install the driver of TP-Link Network Adapter in Windows computer?

  • Try a different PCI slot.
  • Install the adapter on another computer to see if it can be detected.
  • Remove the checkbox before "Allow the computer to turn off this device to save power" in adapter Properties settings> >  Power Management tab

 

0
0
#2
Options
Re:TG-3468 not working after startup, only after restart
2022-01-11 07:44:54

Hi @Solla-topee. Thank you for your answer. I never tried it on a Windows 10 PC and I don't have another computer to try it on. I already have the "Allow the computer to turn off this device to save power" option disabled as I read in another forum that this could be a solution. What I haven't tried is changing the PCI slot.

 

I can't reproduce the problem 100% of times. Sometimes after a powerup it does work, but it mostly doesn't and I need to restart, which always works. It's very strange. 

2
2
#3
Options
Re:TG-3468 not working after startup, only after restart
2022-01-13 06:49:11

Hello @eirismania 

I 'd like to confirm if you installed Win10 X64 driver for TG-3468

https://www.tp-link.com/support/download/tg-3468/

 

Disable other wired network adapters on PC except tp-link adapter

 

To help isolate the issue, you probably need to try this adapter on a different PC like Win10/Win8/Win7  if that is possible.

0
0
#4
Options
Re:TG-3468 not working after startup, only after restart
2022-01-13 08:31:09

@Solla-topee I did this initially. The first driver I used was that one, but it had the same problem. I then used the Realtek one and it has similar problems, although less, I think. I don't have another PC to try it on and the onboard Ethernet is disabled via BIOS.

 

 

0
0
#5
Options