No NAT LOOPBACK? Deco BE85

No NAT LOOPBACK? Deco BE85

No NAT LOOPBACK? Deco BE85
No NAT LOOPBACK? Deco BE85
2023-06-14 22:37:42 - last edited 2024-03-06 03:24:06
Model: Deco BE85  
Hardware Version: V2
Firmware Version: 1.0.7 Build 20230509 Rel. 85648

Just setup new BE22000 system consisting of 3 DECO BE85 units.

    
BE85(2.0). 1.0.7 Build 20230509 Rel. 85648

 

Everything works but NAT Loopback on the port forwarding I setup.

 

I have no security features or QOS enabled on my devices

 

I tried the following testcases:

  • WAN (connected from outside world):   DYNAMIC DNS ADDRESS      -> server is responding 
  • LAN (Connected to DECO WIFI):    LOCAL LAN IP ADDRESS               -> server is responding
  • LAN (Connected to DECO WIFI):    DYNAMIC DNS ADDRESS       -> server is not accesable 

 

Clearly a FIRMWARE bug as seen in other threads. Please fix ASAP!

  3      
  3      
#1
Options
1 Accepted Solution
Re:No NAT LOOPBACK? Deco BE85-Solution
2024-02-27 06:26:16 - last edited 2024-03-06 03:24:06

  @damse 

Hi, Thanks for the update.

The latest 1.0.15 has fixed this issue already.

Deco BE85_V1/V2_1.0.15 Build 20240117

Modifications and Bug Fixes:
1. Improved the stability of the system.
2. Optimized the UI information of the management web page.
3. Support 32-bit subnet mask in Dynamic IP/static IP connection types.
4. Fixed some security issues.
5. Fixed the bug that NAT loopback doesn't work under some special cases.

 

 

PS:The firmware upgrade is applied in sequence to the correct devices during the release process. So not all users get the new firmware notification in the first place. It is suggested to check for firmware upgrades on a regular basis.

 

 

 

Recommended Solution
  1  
  1  
#24
Options
26 Reply
Re:No NAT LOOPBACK? Deco BE85
2023-06-15 02:13:43

  @Dgruhin 

Hi, All Deco models support NAT Loopback.

 

May I know your current DNS server under Deco APP>More>Advanced>DHCP Server>Primary/Second DNS server here?

Maybe the LAN DNS server did not resolve the DDNS domain name properly.

Have you tried to use the WAN IP+ port number to access the server in the local network?

It is also suggested to change the DNS server under DHCP to 8.8.8.8/8.8.4.4 to see whether it helped or not.

 

Wait for your reply.

Best regards.

 

 

 

  1  
  1  
#2
Options
Re:No NAT LOOPBACK? Deco BE85
2023-11-20 15:17:38

  @Dgruhin 

 

Hello,

 

Same problem here.

 

No DNS issue, i can resolv the domain properly. With the IP and port that dont work.

 

Firmware 1.0.13 build 20230927.

 

With my old router that work fine with the same configuration.

 

Thanks to fix this, a router at 40$ can do it, why this BE85 at 700$ cant do this properly ?

  1  
  1  
#3
Options
Re:No NAT LOOPBACK? Deco BE85
2023-12-03 01:20:25 - last edited 2023-12-03 01:21:38

 

 I have same problem please fix it with the next update 

  0  
  0  
#4
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-07 14:14:40 - last edited 2024-01-08 10:13:48

@David-TP 

 

 

 

I have the same issue with satellites.

 

Context:

 

I have 3 deco be85

 

One master (principale in french), and 2 Satellites (firmware 1.0.14 on all devices)

No issue on master node, but I get the issue on satellite.

 

Regards

erreur404

 

  0  
  0  
#5
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-08 10:57:55

  @erreur404 

Hi, Thank you very much for the feedback.

I don't think the issue still existed on the latest firmware 1.0.14.

Did you test the NAT loopback via "WAN IP+Port number" or "DDNS domains+port number"?

May I know how you found out the main Deco BE85 works properly, but not the satellite BE85?

Wait for your reply and best regards.

 

  0  
  0  
#6
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-08 11:05:18 - last edited 2024-01-08 11:48:25

Hello @David-TP 

 

I confirm, I'm on lastest firmware on all be85.

 

Yes I test on WAN ip + natted port

 

On master be85

 

node: WAN ip + natted port OK

Lan IP + port OK

 

On satellite be85 node:

 

WAN ip + natted port KO

Lan IP + port OK

  0  
  0  
#7
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-09 11:38:54

@David-TP 

 

Hello David,

 

Did you reproduce this issue, no you need more information ?

 

Best regards

Erreur404

  0  
  0  
#8
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-10 06:31:41

  @erreur404 

Hi, sorry, I don't have Deco BE85 at hand to confirm the test.

But all Deco units support NAT lookback so I don't think Deco BE85 would miss such a basic feature.

So I was wondering whether you are able to reproduce this issue?

 

I noticed you mentioned the following:

On master be85 node:

WAN ip + natted port OK

Lan IP + port OK

 

On satellite be85 node:

WAN ip + natted port KO

Lan IP + port OK

 

Is the local server connected to the master BE85 or satellite BE85?

 

Thank you very much and best regards.

  0  
  0  
#9
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-10 07:40:53 - last edited 2024-01-10 07:46:13
 
Hello David
 
The server (I suppose the target of WAN ip/port) is connected to satellite.
I reproduce with client connected on any satellite (The server satellite too).
wifi or ethernet
 
Best regards
Erreur404
  1  
  1  
#10
Options
Re:No NAT LOOPBACK? Deco BE85
2024-01-11 07:06:22

  @erreur404 

Thank you very much. I would like to forward your case to the engineers for further assistance. Please check whether you have received my email.

Best regards.

  0  
  0  
#11
Options

Information

Helpful: 3

Views: 1393

Replies: 26