All smart switches reset and now flashing green/orange

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

All smart switches reset and now flashing green/orange

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
All smart switches reset and now flashing green/orange
All smart switches reset and now flashing green/orange
2021-11-28 23:58:22
Model: HS200  
Hardware Version:
Firmware Version:

So I have 17 kasa smart switches throughout my house. I have an Orbi mesh wifi 6 system. I have around 30 smart devices total connected to this network and typically have zero issues. Up until recently all kasa switches worked fine. I installed a new smart switch yesterday for my kitchen and it kept disconnecting, causing me to have to re-link it through the app. I was about to uninstall it completely and decided to relink it one more time. After doing so, suddenly all my switches except for 4 reset and started flashing orange / green. So 14 of my switches are no unreachable and won't operate remotely. Now it looks like I'll need to relink every one manually and assign them to Google home again. I tried resetting my router and modem and reinstalled he kasa app. I have no idea what happened but I don't want to relink every switch if this is going to potentially happen again. Is there an easy way to relink these?

  0      
  0      
#1
Options
4 Reply
Re:All smart switches reset and now flashing green/orange
2021-11-29 06:13:59 - last edited 2021-11-29 06:15:31

Hello @Csukraw 

 May I know was there any power outage or router firmware update before the incident? 

 Please confirm all the Orbi Mesh router + extender are still working fine first.

1. Flashing Amber and green means smart device is ready for set up and need to be reconfigured on the Kasa APP. Very  unusual if this happened to all smart devices. 

2. Flashing Green normally means switch is trying to relink to router/ kasa devices cloud service is affected

You could try to press the ' restart' button on the switch and see if switch could link back to router , check guide here for details: 

The introduction of Signal light on TP-LINK Smart Switch

If restart does not help, try to change router DNS to 8.8.8.8, save settings reboot router, and restart kasa device again. 

 

 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:All smart switches reset and now flashing green/orange
2021-11-29 06:21:41 - last edited 2021-11-29 06:23:36

@Solla-topee yes all other devices and my modem and router are working fine. No power outage. Was in the process of relinking this one new switch when all of them suddenly went offline. I was in the kasa app. Not sure how that could have happened though. They all just reset at once except for 4 of them. All got booted off Google Home as well. 
 

And yes I've tried restarting a few of the switches but all of them are offline and will need to be relinked and set up again. 

  0  
  0  
#3
Options
Re:All smart switches reset and now flashing green/orange
2021-11-29 06:44:32 - last edited 2021-11-29 06:44:50

@Csukraw 

It seems that Router had a moment of disconnection, probably wireless interference or overload of Wi-Fi clients, or channel changing etc.,and all kasa devices are offline. 

- If kasa switch still flash green/ Red Led, you could try to reboot router, wait router to boot up completely then restart switches manually

( try to change router DNS if switch is flashing green)

- If kasa switches are orange and green, that device need to configured again, currently I'm afraid we do not have a quick way to connect all, need relink one by one 

 

To avoid this happens again

1) You may turn off some advanced settings on router like Band steering/ Channel optimization on router

those settings may force device on a different band /change channel and may cause some trouble for smart devices. 

2) you may force kasa device to the closest AP if router allows

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#4
Options
Re:All smart switches reset and now flashing green/orange
2021-12-06 17:27:47
POTENTIAL SOLUTION Hello, I recently had the same issue. I had 4 smart dimmers (HS220) and a power switch (HS300) that started to give me a lot of problems. They were never "available" on the app and constantly looking for the connection, blinking green. Basically they could not be used. I looked quite a bit online and I found several posts here on the forum with similar problems (I posted this in a couple of different threads to reach more people). The common solution I found was to update the firmware to the beta version provided, using the tool linked in those pages. Unfortunately for me the upgrade never worked and I was stucked with the situation. After playing around a lot with both the devices and the network, the conclusion was the problem was the network and not the devices. Playing more (wifi analyzers, static IPs, optimal channels, etc.)  eventually led me to the solution (for me at least). I realized that my phone was causing the problem (Samsung S20). When I moved my phone to the 5Ghz only (leaving all the Kasa devices on the 2.4Ghz), all the devices connected quickly and worked perfectly. Then my wife got home, and as soon as she got in, the switches started to flash the green light. I moved her phone to the 5Ghz network too, but the problem remained. Then I noticed on her phone (iphone) that under the connection settings, there is an option for "private (MAC) address" selected. Deactivating that option, restored all the devices to a perfect working conditions. Sorry for the long story, but I wanted to share with other a simple potential solution that doesn't involve flashing new (beta) firmware. I don't know why this trick makes them working properly, but it does. I woulf like to ask peoplento try and let us know. Thanks SOLUTION: - keep all the phones on the 5Ghz network (with different SSID) - on iPhones, deselect the "provate address" option under the wifi settings
  2  
  2  
#5
Options

Information

Helpful: 0

Views: 2096

Replies: 4

Related Articles