P100 plugs v1.0 not updating to latest firmware

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
P100 plugs v1.0 not updating to latest firmware
P100 plugs v1.0 not updating to latest firmware
2021-12-13 17:28:14 - last edited 2021-12-16 07:20:36
Model: Tapo P100  
Hardware Version: V1
Firmware Version: 1.3.4 33922

I have 8 plugs 2 are V1.2 and 6 V1.0.0
 

4 of the V1.0.0 have upgraded to 1.3.6 37578, but the other have not, even after a full reset.  Any ideas?

  0      
  0      
#1
Options
2 Accepted Solutions
Re:P100 plugs v1.0 not updating to latest firmware-Solution
2021-12-16 17:21:19 - last edited 2022-01-11 01:16:28

@Solla-topee I removed the plugs, waited a few seconds and plugged them back in again.  Then they detected the new firmware and updated okay.

Solla-topee wrote

Hi@Peter170 

Thank you for updated info, do you mean you Unplugging and plug it back, OR Pressing the power button OFF/On did the trick? 

 

Recommended Solution
  2  
  2  
#7
Options
Re:P100 plugs v1.0 not updating to latest firmware-Solution
2022-01-26 07:10:44 - last edited 2022-01-26 07:13:31

Hello @SaunaSherpa 

 

Please try some tips/ suggestions summarized on this thread, thank you

Re:P100 smart plugs won't upgrade to latest 1.4.5 fw-Solution

 

If the above does not work,  kindly help confirm some case details here and we would like to look into that further. 

1. how firmware update failed, please  describe as detailed as possible or attach a photo

2.  Did you try to connect phone to Home Wi-Fi network and try update?

3. Did you try to unplug and plug back and try update ?

4. Model of router:

 network topology, e.g. ISP XX --Router model <WiFi>Tapo P100 

 Does tapo connect to router directly or through extender

5. Mac address of smart plug (please share by private message or email )

 

Thank you 

 

 

 

Recommended Solution
  0  
  0  
#11
Options
10 Reply
Re:P100 plugs v1.0 not updating to latest firmware
2021-12-14 00:50:01

Good day @Peter170 

1. Usually firmware is gradually pushed to smart devices, so some devices may not detect the latest firmware update, while some other could see an available firmware. 

If other device does not available firmware detected in APP, it is suggested waiting for the firmware update in APP. This could take for serveral weeks. 

2. If there is an available firmware in the APP but update failed, can I know which is that firmware version, can I have photo if update failed? Thank you. 

  0  
  0  
#2
Options
Re:P100 plugs v1.0 not updating to latest firmware
2021-12-14 15:05:52 - last edited 2022-01-26 07:11:20

@Peter170 

 

I have faced exactly the same situation. One camera P100 V1 upgraded, the other - not, and when I was checking the firmware, Tapo aplication showed that it did not need firmware update, though in fact it had old firmware version.

I just unplugged it from the socket and plugged it back after 10 seconds. After that Tapo aplication offered firmware upgrade for this camera.

  2  
  2  
#3
Options
Re:P100 plugs v1.0 not updating to latest firmware
2021-12-14 17:44:20

@Solla-topee 

Thanks for getting back to me.  I've just rechecked and the 2 plugs are not showing new firmware.  When I clicked Me button, the new firmware showed but when a clicked it I got the message that all devices were up to date.  I'll get back to you if anything changes.

  2  
  2  
#4
Options
Re:P100 plugs v1.0 not updating to latest firmware
2021-12-15 16:37:53 - last edited 2021-12-17 07:13:32

@Solla-topee All updated. Needed to switch the two plugs off and on in order to get them to update.  Bit of a bug there I think, but all sorted.  Thanks.  

  0  
  0  
#5
Options
Re:P100 plugs v1.0 not updating to latest firmware
2021-12-16 07:19:14

Hi@Peter170 

Thank you for updated info, do you mean you Unplugging and plug it back, OR Pressing the power button OFF/On did the trick? 

  0  
  0  
#6
Options
Re:P100 plugs v1.0 not updating to latest firmware-Solution
2021-12-16 17:21:19 - last edited 2022-01-11 01:16:28

@Solla-topee I removed the plugs, waited a few seconds and plugged them back in again.  Then they detected the new firmware and updated okay.

Solla-topee wrote

Hi@Peter170 

Thank you for updated info, do you mean you Unplugging and plug it back, OR Pressing the power button OFF/On did the trick? 

 

Recommended Solution
  2  
  2  
#7
Options
Re:P100 plugs v1.0 not updating to latest firmware
2022-01-24 10:42:27

@Solla-topee 

Hello, same problem.

  0  
  0  
#8
Options
Re:P100 plugs v1.0 not updating to latest firmware
2022-01-24 19:42:46
@Solla-topee Doesn't work for me.
  0  
  0  
#9
Options
Re:P100 plugs v1.0 not updating to latest firmware
2022-01-24 19:42:47
@Solla-topee Doesn't work for me.
  0  
  0  
#10
Options
Re:P100 plugs v1.0 not updating to latest firmware-Solution
2022-01-26 07:10:44 - last edited 2022-01-26 07:13:31

Hello @SaunaSherpa 

 

Please try some tips/ suggestions summarized on this thread, thank you

Re:P100 smart plugs won't upgrade to latest 1.4.5 fw-Solution

 

If the above does not work,  kindly help confirm some case details here and we would like to look into that further. 

1. how firmware update failed, please  describe as detailed as possible or attach a photo

2.  Did you try to connect phone to Home Wi-Fi network and try update?

3. Did you try to unplug and plug back and try update ?

4. Model of router:

 network topology, e.g. ISP XX --Router model <WiFi>Tapo P100 

 Does tapo connect to router directly or through extender

5. Mac address of smart plug (please share by private message or email )

 

Thank you 

 

 

 

Recommended Solution
  0  
  0  
#11
Options