IP Range Issue after DNS server switching

IP Range Issue after DNS server switching
IP Range Issue after DNS server switching
2021-07-21 15:04:29 - last edited 2021-07-22 03:21:32
Model: Deco
Hardware Version:
Firmware Version:

Hi,

 

This was my set up previously:

 

ATT Router+Modem (Model: BGW320-505). This ATT device doesn't allow turning off DHCP :

Device IPv4 Address 192.168.2.254
DHCPv4 Netmask 255.255.255.0
DHCP Server On
DHCPv4 Start Address 192.168.2.64
DHCPv4 End Address 192.168.2.253

 

ATT router+modem is in IP Passthrough mode.

 

Deco M9 Plus internal IP Range: 192.168.1.1-254

Deco M9 also has a DHCP server active

Deco M9 is getting public IP assigned directly to it. So the passthrough is working properly

I had a rPi with PiHole acting as the DNS server. IP of PiHole was 192.168.1.xx

 

Everything was working perfectly, until yesterday night PiHole stopped working. 

I set the Deco to get DNS automatically. It picked up 192.168.2.254 (this is the IP of the ATT Modem+Router) as the DNS Server.

Then the Decos switched their IP range to 192.168.4.1-254. This breaks up all my IoT settings.

When I try to give 192.168.1.1 as the LAN IP in the Deco, I get the error "LAN IP address and DNS server address (192.168.2.254) cannot be in the same subnet" 

 

How do I get the Deco to switch back to 192.168.1.xx range?

 

P.S. I previously had the same issue and switching the IP range of the ATT Modem+Router from 192.168.1.xx to 192.168.2.xx allowed me to get the Decos to go to the 192.168.1.xx range. Now it is not working in the same setting.

 

Thanks in advance.

 

 

2
2
#1
Options
5 Reply
Re:IP Range Issue after DNS server switching
2021-07-21 17:18:34 - last edited 2021-07-22 03:21:32
I was able to switch back by manually setting the DNS to 8.8.8.8. But I still like it if somebody can explain what's going on and what I did wrong. Manjula
0
0
#2
Options
Re:IP Range Issue after DNS server switching
2021-07-22 06:02:33 - last edited 2021-07-22 06:26:57

@manjulapra 

Hi,

Normally on the Deco, there would be two DNS servers: WAN DNS under IPv4, LAN DNS under DHCP;

There would be two possibilities:

Case 1: you used to set up the LAN DNS as the IP address or the PI-Hole, and after the PI-hole stopped working and it was set back to get DNS automatically, then the new LAN DNS is 192.168.2.254;

So the current LAN settings on Deco would be:

Device IPv4 Address

192.168.1.1

DHCPv4 Netmask

255.255.255.0

DNS server

192.168.2.254

DHCP Server

On

DHCPv4 Start Address

192.168.1.2

DHCPv4 End Address

192.168.1.254

 

Under this case, Have you checked the IP setting under the IPV4 of Deco, and what is the current WAN DNS?

 

Case 2: The Pi-hole was set up as the WAN DNS(192.168.1.xxx) at the beginning and the IP conflict has been here for a long time;

Somehow that PI-hole stopped working yesterday and it was set back to automatic,  finally triggered the IP conflict.

 

Which one would be quite like your case?

 

PS: Deco will use the following information to detect whether there is a conflict.

LAN IP+ subnet mask==WAN IP/WAN DNS/WAN gateway+ subnet mask

If there is a conflict, Deco will change the LAN IP automatically, especially after a reboot.

 

 

0
0
#3
Options
Re:IP Range Issue after DNS server switching
2021-08-01 12:05:10

@TP-Link 

 

You can reproduce this bug everytime by powering off your Deco for a couple minutes. When you power it back on your IP will be 192.168.4.x as it does not keep the subnet you assigned it.

0
0
#4
Options
Re:IP Range Issue after DNS server switching
2021-08-02 08:55:29

@kubbie 

Hi, the issue you have is very likely caused by the IP conflict.

You could refer to the first reply about the IP conflict detecting rules to IPv4 settings and LAN settings whether there would be any IP conflict.

0
0
#5
Options
Re:IP Range Issue after DNS server switching
2021-08-03 13:06:44

Thank you all. I can't test things right now as I am working online scared it will break the network. I will test again soon and see what's causing the issue. Thank you again.

0
0
#6
Options