KL130 Smart Bulbs on EAP225v3 - DTIM Period

KL130 Smart Bulbs on EAP225v3 - DTIM Period
KL130 Smart Bulbs on EAP225v3 - DTIM Period
2021-03-22 18:54:51 - last edited 2021-03-22 19:01:35
Model: KL130
Hardware Version: V2
Firmware Version: 1.0.11

I recently replaced an old ASUS RT-N66U router with an EAP225v3. I now get better wi-fi coverage everywhere in the house, and significantly higher throughput and stability, but I began to notice a lot of regular reconnection events from my KL130B smart bulbs.

 

The "Active Time" on the EAP225 "Client List" table would never show for longer than a few minutes for any of the KL130 bulbs (3 in total). If I checked the DHCP server on my pfSense router, I was seeing the KL130 bulbs were reconnecting approximately every 5 minutes. The reconnection time was different for each bulb, so it wasn't a global wi-fi outage. Each time they reconnected, they would be unresponsive to the Kasa app and Alexa commands, sometimes for a few minutes.

 

There was no obvious reason for them to reconnect - the RSSI values were good from both sides of the link (EAP reporting around -60dBm and the bulbs reporting around -65dBm inside the Kasa app), the DHCP server is configured with static/reserved IPs, and the EAP225 was set to 20Mhz for 2.4GHz and fixed channel, with load balanced and airtime fairness disabled. Other than one old phone, the KL130 bulbs are the only thing using the 2.4GHz band. I originally had the original v2.2 EAP225v3 firmware, but upgraded to the latest 5.0.0 in an attempt to resolve the issue.

 

I discovered that if I would send ICMP pings to the bulbs every 10 seconds, they would remain connected for several hours without dropping. If I stopped pinging and allowed them to go idle, they would drop/reconnect within minutes.

 

This led me to check the "DTIM Period" setting, which is something I've never needed to change on my access points. This defaults to "1" on the EAP225 (and with a beacon interval of 100), whereas the old ASUS router defaulted to a DTIM Period of "3". After changing the EAP225 to "3", the regular reconnection issues stopped and the bulbs are once again stable.

 

Any reason that the KL130 bulbs don't like the shorter DTIM period? All my other devices seem happy with it set to 3, and I see that it's recommended anyway to save battery on mobile devices, but it would be good to know why the KL130 bulbs have a problem with the shorter periods.

0
0
#1
Options
1 Reply
Re:KL130 Smart Bulbs on EAP225v3 - DTIM Period
2021-03-24 02:10:21

@CX23882 Hello, 

 

Thank you very much for your detailed explanation, this requires some advanced troubleshooting, and we would like to escalate this case to our seniors . We emailed you for a follow-up, email subject " 【Forum ID 258194】" please check your inbox, thank you. 

0
0
#2
Options